Ask Your Question
0

Openstack Flat Provider network with openvswitch

asked 2017-05-25 08:46:12 -0500

Vikash Kathirvel gravatar image

I am using https://docs.openstack.org/newton/networking-guide/deploy-ovs-provider.html#deploy-ovs-provider (OVS provider networks) to deploy a flat provider network with openvswitch as the interface driver. Eventually i will move on to self-service networks based on VXLAN.

The docs mention that 2 networks are required, management and provider network. I understood the concept of management network, and my management network is a local 10.0.0.0/8 network with no internet access. But I am struggling to understand the concept of provider networks.

The aim is to provide external access to the instances, correct?

I can access the internet through a TP-Link tl wr941nd router, which provides me IP in the 192.168.0.0/24 network. But the docs mention that "an instance uses a provider (external) network that connects to the physical network infrastructure via layer-2 (bridging/switching). This network includes a DHCP server that provides IP addresses to instances.".

What does this mean? Does it mean that the provider network is the same as the one i use for my hosts to access the internet?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2017-05-26 03:58:17 -0500

In short, the answer to your question is yes. Provider network means a Neutron network that corresponds to an existing network in the datacenter. This is from an all-in-one server I set up with Packstack:

$ ip a
2: enp3s4f0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master ovs-system state UP qlen 1000
    link/ether 78:e7:d1:54:02:80 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::7ae7:d1ff:fe54:280/64 scope link
       valid_lft forever preferred_lft forever
[...]
7: br-ex: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN qlen 1000
    link/ether 78:e7:d1:54:02:80 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.170/24 brd 192.168.1.255 scope global br-ex
       valid_lft forever preferred_lft forever

enp3s4f0 is the physical NIC, connected into br-ex. br-ex carries an IP address from my home network, 192.168.1.0/24. The provider network is named public:

$ openstack network show public
+---------------------------+--------------------------------------+
| Field                     | Value                                |
+---------------------------+--------------------------------------+
[...]
| provider:network_type     | flat                                 |
| provider:physical_network | extnet                               |
| provider:segmentation_id  | None                                 |
[...]
| subnets                   | b9798243-5b76-4adc-a060-e88b855d9f96 |

It is mapped to the physical network extnet, which is defined as follows:

$ sudo grep -r extnet /etc/neutron
/etc/neutron/plugins/ml2/openvswitch_agent.ini:bridge_mappings =extnet:br-ex

When you use network option 2, you usually want to connect your self-service to the external world. That's why you need at least one provider network for option 2 as well.

edit flag offensive delete link more

Comments

By the way, I used this blog entry to set up my networking.

Bernd Bausch gravatar imageBernd Bausch ( 2017-05-26 09:12:04 -0500 )edit

Hi, thanks for your response, but i have a 3 node setup, does it mean i need a br-ex in both network and compute node?

Vikash Kathirvel gravatar imageVikash Kathirvel ( 2017-05-30 03:56:36 -0500 )edit

You need br-ex in the nodes that are connected to the external network. If you use the centralized router, only the network node has br-ex. If you use the distributed router, network and compute nodes.

Bernd Bausch gravatar imageBernd Bausch ( 2017-05-30 07:09:25 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-05-25 08:46:12 -0500

Seen: 176 times

Last updated: May 26 '17