Ask Your Question
1

linux Bridge agent missing option 2 ocata

asked 2017-05-23 16:43:25 -0500

Blade gravatar image

updated 2017-05-24 02:35:24 -0500

Hi everybody! i'm trying to deploy openstack ocata from the official documentation and after configuring neutron i have just 4 list network agent but i must have 5 this is the log file

2017-05-20 13:24:24.994 15755 ERROR neutron.plugins.ml2.drivers.agent._common_agent [-] Failed reporting state!
2017-05-20 13:24:24.994 15755 ERROR neutron.plugins.ml2.drivers.agent._common_agent Traceback (most recent call last):
2017-05-20 13:24:24.994 15755 ERROR neutron.plugins.ml2.drivers.agent._common_agent   File "/usr/lib/python2.7/dist-packages/neutron/plugins/ml2/drivers/agent/_common_agent.py", line 131, in _report_state
2017-05-20 13:24:24.994 15755 ERROR neutron.plugins.ml2.drivers.agent._common_agent     True)
2017-05-20 13:24:24.994 15755 ERROR neutron.plugins.ml2.drivers.agent._common_agent   File "/usr/lib/python2.7/dist-packages/neutron/agent/rpc.py", line 87, in report_state
2017-05-20 13:24:24.994 15755 ERROR neutron.plugins.ml2.drivers.agent._common_agent     return method(context, 'report_state', **kwargs)
2017-05-20 13:24:24.994 15755 ERROR neutron.plugins.ml2.drivers.agent._common_agent   File "/usr/lib/python2.7/dist-packages/oslo_messaging/rpc/client.py", line 169, in call
2017-05-20 13:24:24.994 15755 ERROR neutron.plugins.ml2.drivers.agent._common_agent     retry=self.retry)
2017-05-20 13:24:24.994 15755 ERROR neutron.plugins.ml2.drivers.agent._common_agent   File "/usr/lib/python2.7/dist-packages/oslo_messaging/transport.py", line 97, in _send
2017-05-20 13:24:24.994 15755 ERROR neutron.plugins.ml2.drivers.agent._common_agent     timeout=timeout, retry=retry)
2017-05-20 13:24:24.994 15755 ERROR neutron.plugins.ml2.drivers.agent._common_agent   File "/usr/lib/python2.7/dist-packages/oslo_messaging/_drivers/amqpdriver.py", line 458, in send
2017-05-20 13:24:24.994 15755 ERROR neutron.plugins.ml2.drivers.agent._common_agent     retry=retry)
2017-05-20 13:24:24.994 15755 ERROR neutron.plugins.ml2.drivers.agent._common_agent   File "/usr/lib/python2.7/dist-packages/oslo_messaging/_drivers/amqpdriver.py", line 447, in _send
2017-05-20 13:24:24.994 15755 ERROR neutron.plugins.ml2.drivers.agent._common_agent     result = self._waiter.wait(msg_id, timeout)
2017-05-20 13:24:24.994 15755 ERROR neutron.plugins.ml2.drivers.agent._common_agent   File "/usr/lib/python2.7/dist-packages/oslo_messaging/_drivers/amqpdriver.py", line 339, in wait
2017-05-20 13:24:24.994 15755 ERROR neutron.plugins.ml2.drivers.agent._common_agent     message = self.waiters.get(msg_id, timeout=timeout)
2017-05-20 13:24:24.994 15755 ERROR neutron.plugins.ml2.drivers.agent._common_agent   File "/usr/lib/python2.7/dist-packages/oslo_messaging/_drivers/amqpdriver.py", line 238, in get
2017-05-20 13:24:24.994 15755 ERROR neutron.plugins.ml2.drivers.agent._common_agent     'to message ID %s' % msg_id)
2017-05-20 13:24:24.994 15755 ERROR neutron.plugins.ml2.drivers.agent._common_agent MessagingTimeout: Timed out waiting for a reply to message ID 2ac84a5222af432da8d84da740985c65
2017-05-20 13:24:24.994 15755 ERROR neutron.plugins.ml2.drivers.agent._common_agent 
2017-05-20 13:24:24.995 15755 WARNING oslo.service.loopingcall [-] Function 'neutron.plugins.ml2.drivers.agent._common_agent.CommonAgentLoop._report_state' run outlasted interval by 30.00 sec
2017-05-20 13:24:56.634 15755 INFO neutron.plugins.ml2.drivers.agent._common_agent [-] Stopping ...
(more)
edit retag flag offensive close merge delete

Comments

The Linuxbridge agent on the compute node doesn't get a reply when trying to report its state to the Neutron server. Something wrong with the message queue configuration? Or the clocks are not in sync? Does openstack compute service list show nova-compute?

Bernd Bausch gravatar imageBernd Bausch ( 2017-05-23 17:17:59 -0500 )edit

yes it show the nova compute

Blade gravatar imageBlade ( 2017-05-23 17:41:45 -0500 )edit

This indicates that the clocks are in sync. I would check the clocks anyway, and also check the message queue config of the agent.

Bernd Bausch gravatar imageBernd Bausch ( 2017-05-24 02:37:40 -0500 )edit

the clock is sync and i checked queue config it seems OK

Blade gravatar imageBlade ( 2017-05-24 03:24:18 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2017-05-24 04:42:41 -0500

Blade gravatar image

i have this problem there is no tunnel between the controller node and the compute node neutron.plugins.ml2.drivers.linuxbridge.agent.linuxbridge_neutron_agent [-] Bridge mappings: {} 2017-05-20 12:36:11.161 5625 ERROR neutron.plugins.ml2.drivers.linuxbridge.agent.linuxbridge_neutron_agent [-] Tunneling cannot be enabled without the local_ip bound to an interface on the host. Please configure local_ip None on the host interface to be used for tunneling and restart the agent.

edit flag offensive delete link more

Comments

What's the value of local_ip on that node? It must be the IP address of the tunnel interface. See https://docs.openstack.org/ocata/inst....

Bernd Bausch gravatar imageBernd Bausch ( 2017-05-24 05:30:14 -0500 )edit

the value is 10.0.0.11 (management interface) because i don't have a tunnel interface because they said in the documentation that The example architect uses the management interface to tunnel traffic to the other nodes. Therefore, replace OVERLAY_INTERFACE_IP_ADDRESS with the management IP addres

Blade gravatar imageBlade ( 2017-05-24 07:45:47 -0500 )edit

"Tunneling cannot be enabled without the local_ip bound to an interface on the host" indicates that no NIC has this address. You need a NIC with 10.0.0.11, and you need to set local_ip in the agent config file to 10.0.0.11.

Bernd Bausch gravatar imageBernd Bausch ( 2017-05-24 16:28:26 -0500 )edit

how can i do it please!

Blade gravatar imageBlade ( 2017-05-24 16:51:23 -0500 )edit

If the NIC for tunneling is eth1, ip a add 10.0.0.11/24 dev eth1 adds this IP address to the NIC. I assume that 24 is the correct prefix. It depends on the Linux distro how to make this permanent.

Then set local_ip = 10.0.0.11 in linuxbridge_agent.ini and restart the agent.

Bernd Bausch gravatar imageBernd Bausch ( 2017-05-24 20:43:24 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-05-23 16:43:25 -0500

Seen: 1,790 times

Last updated: May 24 '17