magnum cluster-config wrong port?

asked 2017-05-21 02:38:08 -0600

I have stood up a Swarm cluster according to the installation tutorial, consisting of a master and a node based on Fedora Atomic. The command magnum cluster-config returns DOCKER_HOST=tcp://192.168.1.249:2376.

On the docker master, however, nothing listens on port 2376, which is Docker's TLS port if I am not wrong. The dockerd-current daemon only listens on 2375, the port for non-encrypted communication.

Setting DOCKER_HOST=tcp://192.168.1.249:2375 and adding a security group rule for 2375 allows me to verify the cluster with docker run busybox echo "Hello from Docker!".

Am I doing something wrong, is this a bug in Magnum or in the tutorial?

edit retag flag offensive close merge delete