Ask Your Question
0

How to increase default timeout value of LB ?

asked 2017-05-18 13:05:18 -0500

ospz2014 gravatar image

updated 2017-05-18 13:06:16 -0500

I am seeing that the default timeout comes out to be 50000ms, for server and the client .. I am using HAPROXY , and below is how my config for LBAAS looks -

I am using Juno .. I have been searching this a bit, and my app team is complaining about, a large query, where this timeout is not sufficient ..

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-05-18 13:06:58 -0500

ospz2014 gravatar image

Here is the config -

cat conf global daemon user nobody group nobody log /dev/log local0 log /dev/log local1 notice stats socket /var/lib/neutron/lbaas/9851517f-df80-415e-a211-17bc5290e5a6/sock mode 0666 level user defaults log global retries 3 option redispatch timeout connect 5000 timeout client 50000 timeout server 50000 frontend 1aa92b4b-7e51-48bb-b6b6-16efe1234b78 option tcplog bind IP:PORT mode tcp default_backend 9851517f-df80-415e-a211-17bc5290e5a6 backend 9851517f-df80-415e-a211-17bc5290e5a6 mode tcp balance roundrobin server 295c5b8a-885f-48b6-98ca-5a99c1b93dd3 IP:PORT weight 1 server 2e3b4e05-43d1-4cba-bb6d-c2edc3c9acfc IP:PORT weight 1

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2017-05-18 13:05:18 -0500

Seen: 15 times

Last updated: May 18