Jumbo Frame doesnt work in Ocata-Ubuntu

asked 2017-05-17 16:46:54 -0500

prakashrao gravatar image

I have setup ocata based of ubuntu with one controller node and 2 compute nodes.I have implemented networking using openvswitch.I followed enabling Jumbo frame instructions online https://docs.openstack.org/mitaka/networking-guide/config-mtu.html (https://docs.openstack.org/mitaka/net...)

neutron.conf in controller node [DEFAULT] global_physnet_mtu = 9000

[ml2] path_mtu = 9000 physical_network_mtus = provider:9000

In compute nodes neutron.conf [DEFAULT] global_physnet_mtu = 9000

/ml2/openvswitch_agent.ini [agent] veth_mtu = 9000

I changed all physical nics and br-provider mtu on hosts to 9000(/etc/network/interfaces)

On launching instances I see that virtual interfaces of instances come up with 8950 as mtu but the tap interfaces on compute nodes come up with 1500 mtu

If i am trying ping from one instance to other instance with size greater that 1454 i see that ping is failing

There was a bug in mitaka release https://review.openstack.org/#/c/295917/ which seems to be similar where 9000 is not used while creating bridge.I tried that patch but instance launching fails as i guess that patch was for mitaka.It would be strange if that fix has not gone into ocata!

Any help is appreciated!

edit retag flag offensive close merge delete