Ask Your Question
0

Installing Devstack with Magnum on a VM connected via SSH

asked 2017-05-17 23:17:16 -0500

anonymous user

Anonymous

I am installing devstack with magnum on a VM connected via SSH session. Whenever, I specify PUBLIC_INTERFACE as my ssh'd ip's interface, VM becomes unreachable. I read it https://docs.openstack.org/developer/devstack/guides/neutron.html#using-linux-bridge-instead-of-open-vswitch (here) that we have to use screen, so I tried running screen ./stack.sh but that also doesn't work. Does devstack still run as screen ?

Content of local.conf:

Note: PUBLIC_INTERFACE has same IP as SSH IP. Let say a.b.c.d

  $ cat > /opt/stack/devstack/local.conf << END
  [[local|localrc]]
  DATABASE_PASSWORD=password
  RABBIT_PASSWORD=password
  SERVICE_TOKEN=password
  SERVICE_PASSWORD=password
  ADMIN_PASSWORD=password

  PUBLIC_INTERFACE=eth0

  enable_plugin barbican https://git.openstack.org/openstack/barbican

  enable_plugin heat https://git.openstack.org/openstack/

  enable_plugin magnum https://git.openstack.org/openstack/magnum

  enable_plugin magnum-ui https://github.com/openstack/magnum-ui

  VOLUME_BACKING_FILE_SIZE=20G
  END

As a alternate, I tried to create virtual adaptor and then assigned this interface to PUBLIC_INTERFACE, it was getting installed properly, but when I tried to create a container cluster as specified https://docs.openstack.org/developer/magnum/dev/quickstart.html (here), it failed to create it.

Alternate approach:

Content of local.conf:

Note: PUBLIC_INTERFACE is virtual adaptor lets say eth1. SSH IP is a.b.c.d

  $ cat > /opt/stack/devstack/local.conf << END
  [[local|localrc]]
  DATABASE_PASSWORD=password
  RABBIT_PASSWORD=password
  SERVICE_TOKEN=password
  SERVICE_PASSWORD=password
  ADMIN_PASSWORD=password

  PUBLIC_INTERFACE=eth1

  enable_plugin barbican https://git.openstack.org/openstack/barbican

  enable_plugin heat https://git.openstack.org/openstack/

  enable_plugin magnum https://git.openstack.org/openstack/magnum

  enable_plugin magnum-ui https://github.com/openstack/magnum-ui

  VOLUME_BACKING_FILE_SIZE=20G
  END
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-09-07 08:42:08 -0500

yatin gravatar image

If you have single nic in your devstack host, then you can just comment the line in your local.conf and run stack.sh and it would work for you.:-

PUBLIC_INTERFACE= --> #PUBLIC_INTERFACE=

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-05-17 13:54:58 -0500

Seen: 101 times

Last updated: Sep 07