Ask Your Question
0

Not able to launch instances. Please help

asked 2014-01-19 03:54:20 -0500

Hokam Singh gravatar image

updated 2014-01-24 19:09:10 -0500

smaffulli gravatar image

Hi, On my CentOs6.2 system, I have installed the openstack as specified in the openstack installation guide. In my openstack system, i have one controller node and 2 compute nodes. One compute node is on controller node and other is on different node. I used nova networking for IP allocation. I have following configuration of openstack on my systems.

On my controller and 1st compute node following services run :

  • openstack-nova-api
  • openstack-nova-cert
  • openstack-nova-compute
  • openstack-nova-network
  • openstack-nova-scheduler
  • openstack-nova-conductor
  • openstack-glance-api
  • openstack-glance-registry
  • openstack-keystone
  • openstack-dashboard
  • mysqld
  • libvirtd
  • messagebus
  • qpidd
  • memcached

And on 2nd compute node following services run :

  • openstack-nova-compute
  • openstack-nova-metadata-api
  • openstack-nova-network
  • libvirtd
  • messagebus
  • qpidd
  • memcached

Using the above configuration, when i launch the instance for "cirros" image then the instance run successfully and login to instances also works fine. And when i launch instances for the other images(some downloaded from the openstack site and some created via the virtual box VMDK, VDI and VHD files), then it shows the instance in running state but login to instance fails. For "CentOS" images, some times the console hangs on the green loading screen and does not ask for login credentials and some time it shows the following error messages.

udevd[490]: worker [514] unexpectedly returned with status 0x0100
udevd[490]: worker [514] failed while handling '/devices/LNXSYSTM:00/LNXPWRBN:00/input/input0'
udevd[490]: worker [516] unexpectedly returned with status 0x0100
udevd[490]: worker [516] failed while handling '/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A03:00/device:00'
udevd[490]: worker [524] unexpectedly returned with status 0x0100
udevd[490]: worker [524] failed while handling '/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A03:00/device:01'

And for "Ubuntu" images, console show the logs for more than 40 minutes and after that it shows the login screen.

I am unable to launch instances for CentOS and Ubuntu images using the above configuration. If anybody faced such issue then please assist me to fix it.

edit retag flag offensive close merge delete

Comments

Hi Prathamesh, thanks for the response. My problem is later one. The instance launch works fine and it also goes to running state, but it takes lot of time to go in running state and second, the login to machine does not work. When i log-in to machine, it shows Read from socket failed: Connection reset by peer. Some time it also shows ssh: connect to host 10.0.0.3 port 22: No route to host.

Hokam Singh gravatar imageHokam Singh ( 2014-01-20 08:31:12 -0500 )edit

@hokam-singh: edit your answer to add more details based on the comments: it makes it easier to read

smaffulli gravatar imagesmaffulli ( 2014-01-24 19:08:13 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-01-20 00:01:00 -0500

prathamesh_deshpande gravatar image

Hi Hokam, Are you not able to launch instances other than CirrOS or are you not able to login to the instances ? If you are facing first issue, then can you please paste nova-scheduler/nova-compute logs. For the latter part, try connecting to the instances using the nova keypair: `ssh -i key.pem root@10.0.0.4` this is for the Ubuntu image, key.pem is the keypair and ip of the ubuntu instance is 10.0.0.4 hope this helps

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-01-19 03:54:20 -0500

Seen: 482 times

Last updated: Jan 24 '14