VNC connection problem after publishing horizon to outside [closed]

asked 2017-05-15 10:34:39 -0600

AmirV gravatar image

updated 2017-05-15 10:37:05 -0600

Hi. I published Horizon to outside using a simple port forwarder. Now, users use to connect to horizon. It works fine.

The problem is when they want to connect instance's console, they cannot connect to "controller:6080". In fact, they cannot resolve "controller" name. How can I make horizon to connect to "" instead of "controller:6080"?

I know two possible solutions are to configure DNS server or hosts file for clients who want to connect to horizon. But we don't have permissions to configure DNS server, and also manually configuring hosts file for every client is very difficult.

What do you suggest? Is this anyway to configure horizon to make the requests to instead of controller:6080? However, in this way, administrators who directly work from the local network cannot use VNC, since they are not in network.


edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Bernd Bausch
close date 2017-05-17 04:52:03.446260

1 answer

Sort by ยป oldest newest most voted

answered 2017-05-15 21:40:29 -0600

controller:6080 is the VNC proxy configured in your cloud. You can configure a different address by setting this variable on the compute hosts (DISCLAIMER: I don't know if this precise address works in your network):

novncproxy_base_url =

The admin guide tells you how VNC works in OpenStack and how to configure it; a config example can also be found in the installation guide.

To see all VNC config options, go to the Nova configuration reference and scroll down to "Description of vnc configuration options".

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2017-05-15 10:34:39 -0600

Seen: 105 times

Last updated: May 15 '17