Ask Your Question
0

wget issues on ubuntu image-openstack [closed]

asked 2017-05-10 22:28:32 -0500

sanjana gravatar image

updated 2017-05-10 23:05:23 -0500

I have an ubuntu instance on openstack. I am able to ssh to and from the instance. However i am facing issues in accessing net. wget: unable to resolve host address 'www.google.com' I have modified the /etc/resolv.conf file to include my dns-nameservers. Is there any roundabout for this issue?

Note : I have no proxy settings in my network. I have also ensured that the security group rules are added to the instance. (Allow ssh, all tcp, all icmp, all udp).

Some details regarding my install: 1 have a 2 node openstack newton install in my setup on ubuntu 16.04. I have ml2/linux_bridge setup. I have selected self service networking option during my setup.

I can ping the other nodes in my network from the iinstance. I can also access internet on the controller and compute node, apart from accessing the instance.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by sanjana
close date 2017-05-11 03:33:29.769938

Comments

Hi @sanjana, please try to give more details about your setup, is the machine in a 'provider' or 'self-service' (private) network? Can you reach Internet from your controller host? Also try to reach 8.8.8.8 (google's DNS) and let us know.

gianpietro gravatar imagegianpietro ( 2017-05-10 22:47:43 -0500 )edit

@gianpietro i have selected self-service network for the install. Internet is accessible from the controller,compute node.

sanjana gravatar imagesanjana ( 2017-05-10 23:06:36 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2017-05-11 03:33:14 -0500

sanjana gravatar image

Apparently i had to include the nameserver details in the /etc/resolv.conf file. With this i could access internet.

edit flag offensive delete link more
0

answered 2017-05-10 23:19:03 -0500

@sanjana, if this is a self-service network, you should:

1) Create or make sure there is a 'provider/public' network to have external access. https://docs.openstack.org/newton/ins...

2) Create a Router and connect it to both Provider (external) and Self-service networks. https://docs.openstack.org/newton/ins...

With this, Router should automatically perform Source NAT, so your instance should have connectivity to Internet. You may also need to make sure that the public network is correctly connected to the right bridge or physical interface in your controller/network node.

Let me know if you have any extra doubts during the process.

edit flag offensive delete link more

Comments

@gianpietro thank you for the detailed explanation. I seem to have followed the same. However being a newbie to neutron networking i am not sure if i have configured it correctly. can you help me know if my configurations are correct. If possible can i share my config files and setting here?

sanjana gravatar imagesanjana ( 2017-05-10 23:41:43 -0500 )edit

Yes @sanjana, please go head. You can use http://paste.openstack.org/ if you wish.

gianpietro gravatar imagegianpietro ( 2017-05-10 23:47:07 -0500 )edit

@gianpietro I am sharing the details via paste.openstack.org .setup details PLease let me know if i need to share more details. Horizon settings horizon setup

sanjana gravatar imagesanjana ( 2017-05-11 00:28:14 -0500 )edit

At first it looks fine, let me know if you could create the router and interconnect both networks. Then you could test a ping from your instance to the router (.1) and then to the public network (10.x.x.x)

gianpietro gravatar imagegianpietro ( 2017-05-11 00:37:06 -0500 )edit

ping to the router 10.x.x.6 works fine. Ping to public network is also working. I can access the controller node running on this public network (10.x.x.40). But i cannot ping to my dns-servers at 170.x.x.x.

sanjana gravatar imagesanjana ( 2017-05-11 00:42:56 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-05-10 22:28:32 -0500

Seen: 87 times

Last updated: May 11 '17