Ask Your Question
0

VM instance is not pinging in Redhat osp 10 [closed]

asked 2017-05-10 03:47:43 -0500

chkrishn gravatar image

Hi,

I deployed a redhat osp 10. I have two networks in my overcloud. One in private network (192.168.xx.xx) and other in public (15.xx.xx.xx) for external connectivity. Here are my networks.

neutron net-list
+--------------------------------------+---------+-----------------------------------------------------+
| id                                   | name    | subnets                                             |
+--------------------------------------+---------+-----------------------------------------------------+
| 7f2633e7-63a7-4f5a-a464-201048e172f7 | public  | e3ca5c81-d3d0-46d7-95a6-f0e3532e764d 15.xx.xx.xx/23 |
| bac4ac58-192b-4b5a-bc2b-f18878aec2cb | default | e19a4f99-1bf3-478c-9b07-f65bd4b4c007 192.168.0.0/16 |
+--------------------------------------+---------+-----------------------------------------------------+

 neutron net-show default
+---------------------------+--------------------------------------+
| Field                     | Value                                |
+---------------------------+--------------------------------------+
| admin_state_up            | True                                 |
| availability_zone_hints   |                                      |
| availability_zones        | nova                                 |
| created_at                | 2017-05-10T03:12:46Z                 | 
| description               |                                      |
| id                        | bac4ac58-192b-4b5a-bc2b-f18878aec2cb |   
| ipv4_address_scope        |                                      |
| ipv6_address_scope        |                                      |
| mtu                       | 1446                                 |
| name                      | default                              |
| port_security_enabled     | True                                 |
| project_id                | 4d0af2337f8941c3ac290e8078112c2e     |
| provider:network_type     | vxlan                                |
| provider:physical_network |                                      |
| provider:segmentation_id  | 27                                   |  
| qos_policy_id             |                                      |
| revision_number           | 5                                    |
| router:external           | False                                |
| shared                    | False                                |
| status                    | ACTIVE                               |
| subnets                   | e19a4f99-1bf3-478c-9b07-f65bd4b4c007    |
| tags                      |                                      |
| tenant_id                 | 4d0af2337f8941c3ac290e8078112c2e     |
| updated_at                | 2017-05-10T03:13:34Z                    
|
+---------------------------+--------------------------------------+

 neutron net-show public
+---------------------------+--------------------------------------+
| Field                     | Value                                |
+---------------------------+--------------------------------------+
| admin_state_up            | True                                 |
| availability_zone_hints   |                                      |
| availability_zones        | nova                                 |
| created_at                | 2017-05-10T03:13:58Z                 |
| description               |                                      |
| id                        | 7f2633e7-63a7-4f5a-a464-201048e172f7 |
| ipv4_address_scope        |                                      |
| ipv6_address_scope        |                                      |
| is_default                | False                                |
| mtu                       | 1496                                 |
| name                      | public                               |
| port_security_enabled     | True                                 |
| project_id                | 4d0af2337f8941c3ac290e8078112c2e     |
| provider:network_type     | flat                                 |
| provider:physical_network | datacentre                           |
| provider:segmentation_id  |                                      |
| qos_policy_id             |                                      |
| revision_number           | 6                                    |
| router:external           | True                                 |
| shared                    | False                                |
| status                    | ACTIVE                               |
| subnets                   | e3ca5c81-d3d0-46d7-95a6-f0e3532e764d |
| tags                      |                                      |
| tenant_id                 | 4d0af2337f8941c3ac290e8078112c2e     |
| updated_at                | 2017-05-10T03:15:24Z                 |
+---------------------------+--------------------------------------+

I added ICMP allow in rules.

When I provision a VM with private network, it is not pinging. But when I provision a VM with public network. It is pinging.

i understand VMs take the br-int interface for private connectivity and br-ex for external connectivity (Please correct me if i am wrong)

For external connectivity i added the physical interface eno49 for br-ex bridge using ovs-vsctl add-port br-ex eno49 after which VM with 15.xx.xx.xx started pinging.

I followed the same for the private network by adding ens1f1 (private network is connected to this interface) ovs-vsctl add-port br-int ens1f1.

My overcloud nodes use the interface ens1f0 for their communication.

I would like to know which interface br-int takes for private network connectivity.

Is there anything else that needs to be done to get this working?

Regards Krishna

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by chkrishn
close date 2017-05-11 01:16:43.610947

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-05-10 12:34:30 -0500

updated 2017-05-10 12:37:38 -0500

Don't touch br-int. The openvswitch agent configures it. See the 2nd diagram at https://docs.openstack.org/ocata/netw... - there is an additional bridge, br-tun (don't touch that either).

You map the VXLAN network to ens1f1 by providing the interface's IP address in the openvswitch.ini file on the compute node:

[ovs]
local_ip = IP-ADDRESS-OF-ens1f1

See the same web page, a bit further down. Your br-ex is called br-provider on that page, and your ens1f1 is interface 3.

edit flag offensive delete link more

Comments

Thanks for the information. After creating the bridge and assigning the interface to that bridge and modifying the configuration files mentioning this bridge mappings solved the issue. I am able to ping to private network.

chkrishn gravatar imagechkrishn ( 2017-05-11 01:11:29 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2017-05-10 03:47:43 -0500

Seen: 103 times

Last updated: May 10 '17