Ask Your Question
0

neutron port (liberty) DOWN

asked 2017-05-08 13:27:36 -0600

pyrius gravatar image

updated 2017-05-08 13:49:39 -0600

I have installed fresh openstack liberty via RDO. Created internal and external nets/subnets/ports.

Ports remain DOWN:

[root@alpha ~(keystone_admin)]# neutron port-show d7418afb-548d-4f19-ad67-369cb6ab97a3
+-----------------------+-----------------------------------------------------------------------------------------------------------------------+
| Field                 | Value                                                                                                                 |
+-----------------------+-----------------------------------------------------------------------------------------------------------------------+
| admin_state_up        | True                                                                                                                  |
| allowed_address_pairs |                                                                                                                       |
| binding:host_id       | alpha                                                                                                                 |
| binding:profile       | {}                                                                                                                    |
| binding:vif_details   | {}                                                                                                                    |
| binding:vif_type      | binding_failed                                                                                                        |
| binding:vnic_type     | normal                                                                                                                |
| device_id             | 9d444d6d-a658-4616-a552-676c01b17baf                                                                                  |
| device_owner          | network:router_gateway                                                                                                |
| dns_assignment        | {"hostname": "host-192-168-255-100", "ip_address": "192.168.255.100", "fqdn": "host-192-168-255-100.openstacklocal."} |
| dns_name              |                                                                                                                       |
| extra_dhcp_opts       |                                                                                                                       |
| fixed_ips             | {"subnet_id": "d532231b-5ee5-4cbe-99fa-4fdee35eb009", "ip_address": "192.168.255.100"}                                |
| id                    | d7418afb-548d-4f19-ad67-369cb6ab97a3                                                                                  |
| mac_address           | fa:16:3e:31:c9:62                                                                                                     |
| name                  |                                                                                                                       |
| network_id            | 9aef8486-bb49-4016-91da-8e110e730473                                                                                  |
| security_groups       |                                                                                                                       |
| status                | DOWN                                                                                                                  |
| tenant_id             |                                                                                                                       |
+-----------------------+-----------------------------------------------------------------------------------------------------------------------+

External network has MTU 0:

Created a new network:
+---------------------------+--------------------------------------+
| Field                     | Value                                |
+---------------------------+--------------------------------------+
| admin_state_up            | True                                 |
| id                        | 9aef8486-bb49-4016-91da-8e110e730473 |
| mtu                       | 0                                    |
| name                      | isp-net                              |
| provider:network_type     | flat                                 |
| provider:physical_network | external                             |
| provider:segmentation_id  |                                      |
| router:external           | True                                 |
| shared                    | False                                |
| status                    | ACTIVE                               |
| subnets                   |                                      |
| tenant_id                 | 857bde85f38841afa2c6941992ac64ef     |
+---------------------------+--------------------------------------+

Is "MTU 0" the reason for the port state? How can I change MTU to 1500? Thanks

edit retag flag offensive close merge delete

Comments

1

The port is down because of this detail:

binding:vif_type      | binding_failed

Why the binding failed? Check the Neutron logs.

Similar case: https://ask.openstack.org/en/question...

Bernd Bausch gravatar imageBernd Bausch ( 2017-05-08 16:41:40 -0600 )edit

neutron server.log shows: 2017-05-08 18:17:23.532 3414 WARNING neutron.plugins.ml2.rpc [req-98407d67-353b-4ed5-ba65-35fe56a3ce24 - - - - -] Device 10c70e7e-fd46-4ac4-8523-b0a18fa2a0ab requested by agent ovs-agent-alpha on network 87fb27f3-8ff7-4f19-8bef-eb429ed5dc0e not bound, vif_type: binding_fai

pyrius gravatar imagepyrius ( 2017-05-08 18:01:27 -0600 )edit

The device ID in the log entry is a bit unexpected; on my installation, it's the network interface name, for example tap426ef0ad-56 (but I use Linuxbridge). Other than that, the info in the log entry just reiterates the port details.

Is there anything in the agent log file on host alpha?

Bernd Bausch gravatar imageBernd Bausch ( 2017-05-09 00:38:33 -0600 )edit

In the neutron log I can see that it complains about impossibility to bind different ports on host. ERROR neutron.plugins.ml2.managers [req-4eda7668-7139-4371-9c29-9277c301388a - - - - -] Failed to bind port f0dd85fb-9192-4c86-b493-f701cf09ecca on host alpha looks like Open vSwitch agent is down

pyrius gravatar imagepyrius ( 2017-05-10 17:21:52 -0600 )edit

If the agent is down, yes, binding fails. Try to restart it and check errors if it fails again.

Bernd Bausch gravatar imageBernd Bausch ( 2017-05-10 18:21:19 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2017-05-09 04:59:02 -0600

Rupesh Chowdary gravatar image

Login to the controller node and open the nova.conf file. From there you can set the MTU value.

edit flag offensive delete link more

Comments

Thank you Rupesh, but new networks are still cretaed with MTU 0

pyrius gravatar imagepyrius ( 2017-05-10 17:16:54 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-05-08 13:27:36 -0600

Seen: 53 times

Last updated: May 09