Ask Your Question
0

Connection failure that may be retried.

asked 2017-05-05 10:32:44 -0600

Rahul11 gravatar image

Hi ,

I have installed neutron service on the controller node. When i try to launch the nuetron service i am getting

Connection failure that may be retried.Following link : https://docs.openstack.org/ocata/install-guide-ubuntu/neutron-compute-install.html (https://docs.openstack.org/ocata/inst...)

Installing self service network.

Can anyone please help me with the issue.

Thanks in advance.

edit retag flag offensive close merge delete

Comments

This message is from keystoneauth. My guess is that you misconfigured the [keystone_authtoken] section in neutron.conf.

Bernd Bausch gravatar imageBernd Bausch ( 2017-05-05 18:58:31 -0600 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2017-05-08 01:11:31 -0600

Rahul11 gravatar image

updated 2017-05-08 01:15:02 -0600

Hi @Bernd Bausch

My neutron.conf in Controller node [keystone_authtoken]

auth_uri = http://controller:5000

auth_url = http://controller:35357

memcached_servers = controller:11211

auth_type = password

project_domain_name = default

user_domain_name = default

project_name = service

username = neutron

password = root

==================================================

Also when I am restarting my Keystone service I am getting

root@controller:~# service keystone restart

Failed to restart keystone.service: Unit keystone.service not found.

root@controller:~# systemctl status openstack-keystone

● openstack-keystone.service Loaded: not-found (Reason: No such file or directory) Active: inactive (dead)

edit flag offensive delete link more

Comments

Also I could not see keystone.log file under /var/log/keystone. What could be the issue ??

Rahul11 gravatar imageRahul11 ( 2017-05-08 01:29:40 -0600 )edit

Keystone normally runs under a web server, not as a standalone systemd service. Check if it runs.

The install guide doesn't use auth_uri; not sure if that's significant. Does controller resolve to an IP address?

Bernd Bausch gravatar imageBernd Bausch ( 2017-05-08 03:57:18 -0600 )edit

Hi @Bernd Bausch I am able to run 1. service apache2 restart

but netstat -antup | grep 80 does not shows any tcpv4 connection tcp6 0 0 :::80 :::* LISTEN 17145/apache2 tcp6 0 0 10.136.50.214:80 10.136.50.215:51206 TIME_WAIT

Rahul11 gravatar imageRahul11 ( 2017-05-08 04:33:35 -0600 )edit

2.following this for neutron.conf here under [keystone_authtoken] it uses "auth_uri" https://docs.openstack.org/ocata/install-guide-ubuntu/neutron-controller-install-option2.html (https://docs.openstack.org/ocata/inst...)

Rahul11 gravatar imageRahul11 ( 2017-05-08 04:33:47 -0600 )edit

3.I am able to ping from compute node with controller hostname. But my nslookup fails for controller

Is it making the issue ??

Rahul11 gravatar imageRahul11 ( 2017-05-08 04:33:56 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-05-05 10:32:44 -0600

Seen: 1,401 times

Last updated: May 08 '17