Ask Your Question
0

RDO TripleO QuickStart Undercloud failed

asked 2017-05-05 09:53:17 -0500

kyomster gravatar image

Hello,

I'm trying to install TripleO QuickStart on CentOS 7 but it failed at the "Install the undercloud". The error is:

TASK [undercloud-deploy : Install the undercloud] ******************************
task path: /root/.quickstart/usr/local/share/ansible/roles/undercloud-deploy/tasks/install-undercloud.yml:15
Friday 05 May 2017  11:39:57 +0000 (0:00:07.869)       0:18:53.032 ************
fatal: [undercloud]: FAILED! => {"changed": true, "cmd": "set -o pipefail && /home/stack/undercloud-install.sh 2>&1 | awk '{ print strftime(\"%Y-%m-%d %H:%M:%S |\"), $0; fflush(); }' > /home/stack/undercloud_install.log", "delta": "0:44:49.399170", "end": "2017-05-05 12:24:51.173525", "failed": true, "rc": 1, "start": "2017-05-05 11:40:01.774355", "stderr": "", "stdout": "", "stdout_lines": [], "warnings": []}

PLAY RECAP *********************************************************************
163.172.168.222            : ok=110  changed=55   unreachable=0    failed=0
localhost                  : ok=18   changed=8    unreachable=0    failed=0
undercloud                 : ok=6    changed=5    unreachable=0    failed=1

Do you know what is going wrong ?

Thanks.

edit retag flag offensive close merge delete

Comments

To support you I need details ( step by step ) VIRTHOST and WKS set up procedure. Quickstart starting CMD.

dbaxps gravatar imagedbaxps ( 2017-05-05 14:42:56 -0500 )edit

Here are the details: https://pastebin.com/ncjbbGZw

kyomster gravatar imagekyomster ( 2017-05-06 07:11:14 -0500 )edit

"provided hosts list is empty, only localhost is available" seems to be core issue.
Once again see correct VIRTHOST and Workstation (f24/25) set up. It was not done as required.
Tripleoi QS won't start properly.

dbaxps gravatar imagedbaxps ( 2017-05-06 08:09:05 -0500 )edit

VIRTHOST is just one host, it's a simple install of CentOS 7.

Workstation is also CentOS 7.

I simply installed 2 CentOS, one on VIRTHOST having 60GB memory and 250GB disk with 10 cores, the other one for workstation.

commands executed on workstation are: https://pastebin.com/CxcXG2Bw

kyomster gravatar imagekyomster ( 2017-05-06 08:31:21 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-05-05 15:09:53 -0500

dbaxps gravatar image

updated 2017-05-06 09:15:06 -0500

UPDATE 05/05/17
Per your pastebin text

VIRTHOST=163.172.155.195
ssh-keygen
ssh-copy-id root@163.172.168.222
ssh root@$VIRTHOST uname -a
git clone https://github.com/openstack/tripleo-quickstart
cd tripleo-quickstart
bash quickstart.sh --install-deps
bash quickstart.sh $VIRTHOST

Where you copy ssh-key ? to 163.172.168.222 . Your VIRTHOST has different IP
Does ssh root@$VIRTHOST uname -a work with no root password requested ?
END UPDATE

Using field as comment now.
Recently standard quickstart.sh starting deploying rules have been updated
Please be aware of
TripleO QuickStart Ocata branch Deployment with feature sets and nodes configuration (topology) separated
http://dbaxps.blogspot.com/2017/04/tr...
VIRTHOST should have 32 GB and 4 CORE CPU at least.
Regarding initial VIRTHOST and WKS set up* <=== problem is here.
https://simplenfv.wordpress.com/2016/...
http://dbaxps.blogspot.com/2016/06/at...
Both blogs were written a while ago, **so ignore suggested quickstart.sh CMD in posts above
follow updated rules from my the most recent posting,mentioned the first.
Doing TripleO QS deploying Ocata branch you might easily fail with 32 GB VIRTHOST or deployed non-functional
overcloud. In case Ocata release I suggest 48 GB and 8 CORE CPU on VIRTHOST
SHORTAGE of RAM on VIRTHOST (top monitoring) might have unpredictable consequences for TripleO QS.
During overcloud deployment itself or report success and build overcloud topology having issues like disability create cinder volume on ceph nodes or whatever.

edit flag offensive delete link more

Comments

yes it works without root password requested.

also, I tried twice with 2 different host (one with 32GB memory, the other 60GB memory) hence my bad copy/paste with 2 different IPs in pastebin but good IP was used for deployment

kyomster gravatar imagekyomster ( 2017-05-06 11:08:44 -0500 )edit

when I do "virsh list" on VIRTHOST I get

Id Name State


1 undercloud running

kyomster gravatar imagekyomster ( 2017-05-06 11:10:47 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-05-05 09:53:17 -0500

Seen: 115 times

Last updated: May 06