Ask Your Question
0

Horizon cannot connect to Keystone

asked 2017-05-05 09:03:05 -0500

Yrez gravatar image

Hello everyone,

Last day, i installed OpenStack thanks to Devstack on Ubuntu 16.04 and Horizon worked, i could log as admin. However, today, when i started horizon, i could not connect, and I have this answer from horizon : "An error occurred authenticating. Please try again later.".

I can read on file /var/log/apache2/horizon_error.log :

2017-05-05 15:40:03.429306 failed to make connection to backend: httpd-UDS:0

2017-05-05 15:40:03.432566 AH02454: uwsgi: attempt to connect to Unix domain socket /var/run/uwsgi/keystone-wsgi-public.socket (uwsgi-uds-keystone-wsgi-public) failed

2017-05-05 15:40:03.432579 AH00959: ap_proxy_connect_backend disabling worker for (uwsgi-uds-keystone-wsgi-public) for 0s

It seems that horizon cannot connect to Keystone.

Could you help me please ?

edit retag flag offensive close merge delete

Comments

Similar case. Did you reboot the system that runs DevStack?

Bernd Bausch gravatar imageBernd Bausch ( 2017-05-06 17:26:36 -0500 )edit

3 answers

Sort by » oldest newest most voted
0

answered 2017-05-09 09:54:37 -0500

Can you verify if keystone is running sudo systemctl status devstack@keystone

try to start it but will fail
sudo systemctl start devstack@keystone

seems a recent issue has caused keystone to not to start if one reboots a devstack server I have been rebooting devstack installation for years without issue

if you restack it will work again but don't reboot

hope this helps

edit flag offensive delete link more

Comments

Answer above.

Yrez gravatar imageYrez ( 2017-05-10 06:45:44 -0500 )edit
0

answered 2017-05-10 02:36:12 -0500

Yrez gravatar image

updated 2017-05-10 02:39:50 -0500

Hello, I tried :

Thanks for your answer.

I tried :

~$ sudo systemctl status devstack@keystone ● devstack@keystone.service - Devstack devstack@keystone.service Loaded: loaded (/etc/systemd/system/devstack@keystone...; enabled; vendor preset: enabled) Active: failed (Result: exit-code) since mer. 2017-05-10 09:18:29 CEST; 9min ago Process: 815 ExecStart=/usr/local/bin/uwsgi --ini /etc/keystone/keystone-uwsgi-public.ini (code=exited, status=1/FAILURE) Main PID: 815 (code=exited, status=1/FAILURE) Status: "initializing uWSGI"

mai 10 09:18:28 alexis-OpenStack devstack@keystone.service[815]: your processes number limit is 15633 mai 10 09:18:28 alexis-OpenStack devstack@keystone.service[815]: your memory page size is 4096 bytes mai 10 09:18:28 alexis-OpenStack devstack@keystone.service[815]: detected max file descriptor number: 1024 mai 10 09:18:28 alexis-OpenStack devstack@keystone.service[815]: lock engine: pthread robust mutexes mai 10 09:18:28 alexis-OpenStack devstack@keystone.service[815]: thunder lock: enabled mai 10 09:18:28 alexis-OpenStack devstack@keystone.service[815]: bind(): No such file or directory [core/socket.c line 230] mai 10 09:18:29 alexis-OpenStack systemd[1]: devstack@keystone.service: Main process exited, code=exited, status=1/FAILURE mai 10 09:18:29 alexis-OpenStack systemd[1]: Failed to start Devstack devstack@keystone.service. mai 10 09:18:29 alexis-OpenStack systemd[1]: devstack@keystone.service: Unit entered failed state. mai 10 09:18:29 alexis-OpenStack systemd[1]: devstack@keystone.service: Failed with result 'exit-code'.

And then, i tried to restart :

~$ sudo systemctl start devstack@keystone Job for devstack@keystone.service failed because the control process exited with error code. See "systemctl status devstack@keystone.service" and "journalctl -xe" for details.

So, I should not reboot openstack server, otherwise it will fail ?

How could I restack? Should I unstack, and then, stack ?

edit flag offensive delete link more

Comments

Depending on how they are deployed, OpenStack servers can be rebooted, but DevStack normally not.

You could check the journal to find pertinent error descriptions. There seems to be a problem binding to a socket. Perhaps there is a uwsgi log as well.

Bernd Bausch gravatar imageBernd Bausch ( 2017-05-10 02:45:04 -0500 )edit

That only happened when i reboot my server (which is a VM on my laptop) but I cannot let this VM ON all the time. So, how could i deploy openstack ?

Yrez gravatar imageYrez ( 2017-05-10 06:44:27 -0500 )edit

Either use another deployment method like Packstack. Or don't reboot the VM, but save its state.

Bernd Bausch gravatar imageBernd Bausch ( 2017-05-10 07:33:05 -0500 )edit

one can reboot a devstack environment, been doing that for years without issue. I'm seeing the same issue after devstack recently added systemclt services. Try this: Add this to /etc/rc.local: mkdir /var/run/uwsgi chown stack /var/run/uwsgi stack=your user systemctl restart devstack@keystone

steve137 gravatar imagesteve137 ( 2017-05-10 11:04:58 -0500 )edit

I do not understand what you mean :

mkdir /var/run/uwsgi 
chown stack /var/run/uwsgi 
stack=youruser systemctl restart devstack@keystone
Yrez gravatar imageYrez ( 2017-05-11 04:14:23 -0500 )edit
0

answered 2018-05-15 11:40:34 -0500

Have you changed the ip assgined on the interface? you should verify the keystone endpoints, I installed devstack too and i received that error and I solved it putting the same ip in the interface wlan, even this interface does not in use.

edit flag offensive delete link more

Comments

If you speak spanish I can explain it in spanish, beacause in english is very dificult to me.

frankart gravatar imagefrankart ( 2018-05-15 11:42:42 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-05-05 08:45:18 -0500

Seen: 725 times

Last updated: May 10 '17