unable to launch instance topic: "network", RPC method: "validate_networks" info: "<unknown>"

asked 2014-01-17 07:01:15 -0500

Malleshi gravatar image

==> nova-api.log <== 2014-01-17 08:50:42.131 3220 ERROR nova.api.openstack [req-9af093e0-ce9d-4325-899a-b7c733a2a828 4c0ce2bfdd6c4b4b932c87f188288e3b c21ebb4b4b8543e4a36cdd20385a05ad] Caught error: Timeout while waiting on RPC response - topic: "network", RPC method: "validate_networks" info: "<unknown>" 2014-01-17 08:50:42.131 3220 TRACE nova.api.openstack Traceback (most recent call last): 2014-01-17 08:50:42.131 3220 TRACE nova.api.openstack File "/usr/lib/python2.7/dist-packages/nova/api/openstack/__init__.py", line 119, in __call__ 2014-01-17 08:50:42.131 3220 TRACE nova.api.openstack return req.get_response(self.application) 2014-01-17 08:50:42.131 3220 TRACE nova.api.openstack File "/usr/lib/python2.7/dist-packages/webob/request.py", line 1296, in send 2014-01-17 08:50:42.131 3220 TRACE nova.api.openstack application, catch_exc_info=False) 2014-01-17 08:50:42.131 3220 TRACE nova.api.openstack File "/usr/lib/python2.7/dist-packages/webob/request.py", line 1260, in call_application 2014-01-17 08:50:42.131 3220 TRACE nova.api.openstack app_iter = application(self.environ, start_response) 2014-01-17 08:50:42.131 3220 TRACE nova.api.openstack File "/usr/lib/python2.7/dist-packages/webob/dec.py", line 144, in __call__ 2014-01-17 08:50:42.131 3220 TRACE nova.api.openstack return resp(environ, start_response) 2014-01-17 08:50:42.131 3220 TRACE nova.api.openstack File "/usr/lib/python2.7/dist-packages/keystoneclient/middleware/auth_token.py", line 539, in __call__</unknown>

edit retag flag offensive close merge delete

Comments

I'm pretty sure that all your services are working. If not please ensure that all your services are running. You are mixing or messing your configuration in either nova.conf or neutron.conf. Please check your configuration. It will be alright.

dheeru gravatar imagedheeru ( 2014-01-17 20:29:36 -0500 )edit

Hello Dheeru , Thanks for your reply.... I am testing openstack on 6 nodes. 1.mysql-rabbitmq 2.keystone-dashboard ,3.image-cinder 4.kvm-computenode 5.nova-services 6.neutron... I checked all services. its showing running with :) please refer below errors ==> openvswitch-agent.log <==2014-01-17 11:07:13.532 5807 ERROR neutron.agent.linux.ovs_lib [-] Unable to execute ['ovs-vsctl', '--timeout=2', 'list-ports', 'br-int']. Exception: Command: ['sudo', '/usr/bin/neutron-rootwrap', '/etc/neutron/rootwrap.conf', 'ovs-vsctl', '--timeout=2', 'list-ports', 'br-int'] Exit code: 1 Stdout: '' Stderr: '2014-01-17T05:37:13Z|00001|reconnect|WARN|unix:/var/run/openvswitch/db.sock: connection attempt failed (No such file or directory)\novs-vsctl: unix:/var/run/openvswitch/db.sock: database connection failed (No such file or directory)\n' ==> l3-agent.log <== 2014-01-17 11:36:24.255 18281 ERROR neutron.agent.l3_agent [-] Failed synchronizing routers 2014-01-17 11:36:24.255 18281 TRACE neut

Malleshi gravatar imageMalleshi ( 2014-01-18 03:39:49 -0500 )edit