Ask Your Question
0

How can I setup private/public network for access Instance from external network

asked 2017-05-02 23:32:33 -0500

Teera W. gravatar image
 I tried to setup Network in RedHat OpenStack. By my scenario is shown below:

Private 
 Subnet:    192.168.1.0/24
 GW:        192.168.1.1
 Pool:      192.168.1.50,192.168.1.70
== Router 192.168.1.254 ==
Public  
 Subnet:    192.168.80.0/24
 GW:        192.168.80.254
 Pool:      192.168.80.50,192.168.80.70
===
My Instance
 IP: 192.168.1.56
 GW: 192.168.1.1
===
OpenStack Host
 Subnet:    192.168.80.134
 GW:        192.168.80.2
===
My Laptop
 IP:    192.168.80.1
===

But I cannot SSH into my Instance, both from OpenStack host, and from my laptop.
I'm newbie for Network configuration area, please recommend.
edit retag flag offensive close merge delete

Comments

Could you attach a screenshot of the network topology from horizon here? Also try pinging the router interface and router gateway from your vm in the first place. Associate a floating IP to your vm instance. Only then will you be able to ssh into.

sanjana gravatar imagesanjana ( 2017-05-03 01:11:40 -0500 )edit

Sorry, my score is <10, so I cannot attach image, but I upload to this url: https://ibb.co/eCSHD5

And, I cannot ping to router interface and route gateway.

Teera W. gravatar imageTeera W. ( 2017-05-03 02:17:19 -0500 )edit

can you access internet from your external network? Could you try associating floating IP to the vm instance?

sanjana gravatar imagesanjana ( 2017-05-03 03:54:37 -0500 )edit

Also what is the type of external network that you have created? flat, vlan, vxlan? could you share more details on the external network?

sanjana gravatar imagesanjana ( 2017-05-03 04:01:12 -0500 )edit

From my OpenStack host (192.168.80.134) can acesss internet, but public network that floating ip is 192.168.80,65 can't access internet. Is it problem if my external network is in same segment with my Openstack host.

Note: My external network is vxlan type.

Thanks.

Teera W. gravatar imageTeera W. ( 2017-05-03 04:47:43 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-05-08 05:37:01 -0500

Teera W. gravatar image

Hi Bernd, Sanjana,

I have successfully configured the OpenStack network. Problem is when OpenStack installed completed, the virtual adapter named br-ex is up and set initial network as DEMO configuration 172.x.x.x, and this br-ex will down after reboot. Before there is no network script to start up this interface. So I have followed steps in this two links to completed re-setup br-ex

https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/10/html/networking_guide/openstack_networking_concepts#provider_networks (https://access.redhat.com/documentati...)

https://www.rdoproject.org/networking/neutron-with-existing-external-network/ (https://www.rdoproject.org/networking...)

After reboot br-ex is used exisiting network configuration (IP, Gateway), and public network is work fine

Thank you very much for your help.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-05-02 23:32:33 -0500

Seen: 1,770 times

Last updated: May 08 '17