Ask Your Question
0

tacker installation error generating tacker.conf

asked 2017-04-29 05:39:07 -0500

AnLaoch gravatar image

I am following the Tacker installations using the instructions here: https://docs.openstack.org/developer/...

At the point where I am to Generate the tacker.conf.sample I come across the following errors. Note that the installation of requirements.txt had been successful earlier in the install process.

controller:~$ sudo pip install -r tacker/requirements.txt

Method #1

Here is the error when trying the script in tools method.

osbash@controller:~/tacker/tools$ ./generate_config_file_sample.sh 
Traceback (most recent call last):
  File "/usr/local/bin/oslo-config-generator", line 11, in <module>
    sys.exit(main())
  File "/usr/local/lib/python2.7/dist-packages/oslo_config/generator.py", line 529, in main
    conf(args, version=version)
  File "/usr/local/lib/python2.7/dist-packages/oslo_config/cfg.py", line 2372, in __call__
    raise ConfigFilesNotFoundError(self._namespace._files_not_found)
oslo_config.cfg.ConfigFilesNotFoundError: Failed to find some config files: /home/osbash/tacker/tools/etc/config-generator.conf

Method #2

Here is the error when trying the tox config-gen method.

osbash@controller:~/tacker$ tox -e config-gen config-gen create: /home/osbash/tacker/.tox/config-gen config-gen installdeps:
-r/home/osbash/tacker/requirements.txt,
-r/home/osbash/tacker/test-requirements.txt, setuptools-git>=0.4

...............Pages of errors .................

-------------------------- summary -------------------------- ERROR:   config-gen: could not install deps [-r/home/osbash/tacker/requirements.txt,
-r/home/osbash/tacker/test-requirements.txt, setuptools-git>=0.4]; v = InvocationError('/home/osbash/tacker/.tox/config-gen/bin/pip install -U
-chttps://git.openstack.org/cgit/openstack/requirements/plain/upper-constraints.txt
-r/home/osbash/tacker/requirements.txt -r/home/osbash/tacker/test-requirements.txt setuptools-git>=0.4 (see /home/osbash/tacker/.tox/config-gen/log/config-gen-1.log)', 1)
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-05-05 09:56:15 -0500

AnLaoch gravatar image

updated 2017-05-05 09:59:51 -0500

There is some problem with the config-gen but here is a work around that worked for me. I looked in the log at what was failing and tried to run each bit individually. I descovered that I needed to install build-essential libssl-dev libffi-dev python-dev, tox with pip and not apt-get. Even still the tox -e config-gen failed. So running things in this order worked.

osbash@controller:~/tacker$ sudo apt-get install build-essential libssl-dev libffi-dev python-dev

osbash@controller:~/tacker$ sudo -H pip install -r requirements.txt
osbash@controller:~/tacker$ sudo -H pip install -r test-requirements.txt
osbash@controller:~/tacker$ sudo -H pip install setuptools-git>=0.4
osbash@controller:~/tacker$ sudo -H pip install -U -chttps://git.openstack.org/cgit/openstack/requirements/plain/upper-constraints.txt -e ./

osbash@controller:~/tacker$ sudo -H tox -e config-gen
config-gen create: /home/alovelace/tacker/.tox/config-gen
config-gen installdeps: -r/home/alovelace/tacker/requirements.txt, -r/home/alovelace/tacker/test-requirements.txt, setuptools-git>=0.4
config-gen develop-inst: /home/alovelace/tacker
config-gen installed: alabaster==0.7.10,alembic==0.9.1,amqp==2.1.3,anyjson==0.3.3,appdirs==1.4.3,asn1crypto==0.22.0,Babel==2.3.4,beautifulsoup4==4.5.3,cachetools==2.0.0,cffi==1.10.0,chardet==3.0.2,cliff==2.6.0,cmd2==0.7.0,contextlib2==0.5.5,coverage==4.3.4,cryptography==1.8.1,debtcollector==1.13.0,decorator==4.0.11,doc8==0.8.0,docutils==0.13.1,dulwich==0.17.3,enum-compat==0.0.2,enum34==1.1.6,eventlet==0.20.1,extras==1.0.0,fasteners==0.14.1,fixtures==3.0.0,flake8==2.5.5,funcsigs==1.0.2,functools32==3.2.3.post2,futures==3.1.1,futurist==1.1.0,greenlet==0.4.12,hacking==0.12.0,heat-translator==0.8.0,idna==2.5,imagesize==0.7.1,ipaddress==1.0.18,iso8601==0.1.11,Jinja2==2.9.6,jsonpatch==1.15,jsonpointer==1.10,jsonschema==2.6.0,keystoneauth1==2.20.0,keystonemiddleware==4.15.0,kombu==4.0.1,linecache2==1.0.0,Mako==1.0.6,MarkupSafe==1.0,mccabe==0.2.1,mock==2.0.0,monotonic==1.3,mox3==0.21.0,msgpack-python==0.4.8,netaddr==0.7.19,netifaces==0.10.5,openstackdocstheme==1.8.0,ordereddict==1.1,os-api-ref==1.3.0,os-client-config==1.27.0,os-testr==0.8.1,osc-lib==1.6.0,oslo.concurrency==3.20.0,oslo.config==3.24.0,oslo.context==2.13.0,oslo.db==4.21.0,oslo.i18n==3.15.0,oslo.log==3.26.0,oslo.messaging==5.23.0,oslo.middleware==3.26.0,oslo.policy==1.22.0,oslo.reports==1.19.0,oslo.rootwrap==5.7.0,oslo.serialization==2.18.0,oslo.service==1.23.0,oslo.utils==3.25.0,oslosphinx==4.12.0,oslotest==2.15.0,packaging==16.8,paramiko==2.1.2,Paste==2.0.3,PasteDeploy==1.5.2,pbr==3 ...
(more)
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-04-29 05:39:07 -0500

Seen: 231 times

Last updated: May 05 '17