Ask Your Question
0

Ocata Neutron Error : Interface name must be shorter than IFNAMSIZ (15)

asked 2017-04-28 16:00:22 -0500

jkilborn gravatar image

I'm setting up ocata on a new environment, and have everything running. My vms wont spawn without an error when it tries to setup the interface in neutron. I can see in the neutron-openvswitch logs that its failing due to trying to apply iptables rules. Seems its using a long interface name for some reason.

ERROR neutron.plugins.ml2.drivers.openvswitch.agent.ovs_neutron_agent ; Stdout: ; Stderr: iptables-restore v1.4.21: interface name `3a3dddce-4752-4ddb-8442-6ef69b7e0fbd' must be shorter than IFNAMSIZ (15)

Any idea if this is the name it should be using? I think its the neutron port-id, but its over 15 chars. Why isn't it using the tap name?

Here are the setting I have uncommented in openvswitch_agent.ini

[DEFAULT]
debug = true
[agent]
tunnel_types = vxlan
l2_population = true
[ovs]
local_ip = XXX.XXX.XXX.XXX
bridge_mappings = provider:br-provider
[securitygroup]
firewall_driver = neutron.agent.linux.iptables_firewall.IptablesFirewallDriver
enable_security_group = true
enable_ipset = true
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2017-05-01 02:29:20 -0500

kevinbenton gravatar image

If you're using the openvswitch agent you should be using the OVSHybridIptablesFirewallDriver instead of IptablesFirewallDriver.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2017-04-28 16:00:22 -0500

Seen: 480 times

Last updated: May 01 '17