Failed to create resource provider record in placement API got 404 error

asked 2017-04-25 09:39:16 -0500

anonymous user

Anonymous

updated 2017-04-26 13:55:20 -0500

Hi All,

I have configured the openstack - Ocata manually in my test environment where we have 2 controllers and 2 computes with HA configured.

I am seeing continuous error logs in my compute nodes as below:

2017-04-25 14:17:18.768 1081 ERROR nova.scheduler.client.report [req-8e120b50-d9c6-4793-8683-eed5275e5900 - - - - -] Failed to create resource provider record in placement API for UUID e149da94-cfec-4d6c-9ec9-2962802ab89b. Got 404: <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>404 Not Found</title>
</head><body>
<h1>Not Found</h1>
<p>The requested URL /placement/resource_providers was not found on this server.</p>
</body></html>
2017-04-25 14:17:18.769 1081 WARNING nova.scheduler.client.report [req-8e120b50-d9c6-4793-8683-eed5275e5900 - - - - -] Unable to refresh my resource provider record

Here you find the details about my setup:

/etc/nova/nova.conf

[DEFAULT]
enabled_apis = osapi_compute,metadata
transport_url = rabbit://rabbitmq:4598954baf92c4d8edd6@psusnjhhdlc7iosc02con001
my_ip = 192.168.15.13
use_neutron = True
firewall_driver = nova.virt.firewall.NoopFirewallDriver
# ask api to listen to a specific ip. Reuqired if haproxy is in this controller
osapi_compute_listen=192.168.15.13
metadata_listen = 192.168.15.13
debug = True
[api_database]
connection = mysql+pymysql://nova:2259adc8d9a652f31886@192.168.15.202/nova_api
[database]
connection = mysql+pymysql://nova:2259adc8d9a652f31886@192.168.15.202/nova
[api]
auth_strategy = keystone
[keystone_authtoken]
auth_uri = http://192.168.15.201:5000
auth_url = http://192.168.15.201:35357
memcached_servers = psusnjhhdlc7iosc02con001:11211,psusnjhhdlc7iosc02con002:11211 
auth_type = password
project_domain_name = Default
user_domain_name = Default
project_name = service
username = nova
password = c1cc3bd5db0787272ba3

[vnc]
enabled = true
vncserver_listen = $my_ip
vncserver_proxyclient_address = $my_ip

[glance]
api_servers = http://192.168.15.201:9292

[oslo_concurrency]
lock_path = /var/lib/nova/tmp

[placement]
os_region_name = usnjcnis001 
project_domain_name = Default
project_name = service
auth_type = password
user_domain_name = Default
auth_url = http://192.168.15.201:35357/v3
username = placement
password = 282d63a9cb7f1d43cb48

[neutron]
url = http://192.168.15.201:9696
auth_url = http://192.168.15.201:35357
auth_type = password
project_domain_name = default
user_domain_name = default
region_name = usnjcnis001
project_name = service
username = neutron
password = 1c3d91db12256871d396
#service_metadata_proxy = true
#metadata_proxy_shared_secret = METADATA_SECRET

[cinder]
os_region_name = usnjcnis001

/etc/httpd/conf.d/00-nova-placement-api.conf

Listen 8778

<VirtualHost *:8778>
  WSGIProcessGroup nova-placement-api
  WSGIApplicationGroup %{GLOBAL}
  WSGIPassAuthorization On
  WSGIDaemonProcess nova-placement-api processes=3 threads=1 user=nova group=nova
  WSGIScriptAlias / /usr/bin/nova-placement-api
  <IfVersion >= 2.4>
    ErrorLogFormat "%M"
  </IfVersion>
  ErrorLog /var/log/nova/nova-placement-api.log
  #SSLEngine On
  #SSLCertificateFile ...
  #SSLCertificateKeyFile ...
<Directory /usr/bin>
   <IfVersion >= 2.4>
      Require all granted
   </IfVersion>
   <IfVersion < 2.4>
      Order allow,deny
      Allow from all
   </IfVersion>
</Directory>
</VirtualHost>

Alias /nova-placement-api /usr/bin/nova-placement-api
<Location /nova-placement-api>
  SetHandler wsgi-script
  Options +ExecCGI
  WSGIProcessGroup nova-placement-api
  WSGIApplicationGroup %{GLOBAL}
  WSGIPassAuthorization On
</Location>

Appreciate your help/suggestions on this,if any. Thanks, Nakul J Andeo

edit retag flag offensive close merge delete

Comments

Is placement endpoint running in HAproxy, ports bind?

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2017-04-26 13:57:37 -0500 )edit

Eduardo - Yes i am using Haproxy for all the service port binding.I tried for placement service but it wont helped me.All service endpoints are pointing to Virtual ip (192.168.15.201)

nakul_redhat gravatar imagenakul_redhat ( 2017-04-27 04:04:08 -0500 )edit

Could you confirm if your admin,public and internal endpoints for placement service are http://<ip-of-controller>:8778

DarkKnight gravatar imageDarkKnight ( 2017-04-28 01:22:43 -0500 )edit

Also i checked your nova.conf file contents, could you add the below field [placement_database] connection = mysql+pymysql://nova:nova123@controller/nova_api restart the nova and httpd services and then paste the o/p of "nova-status upgrade check"

DarkKnight gravatar imageDarkKnight ( 2017-04-28 01:26:35 -0500 )edit

As per the Bug #1683585 reported by Darren McGrandle on 2017-04-18,I updated the endpoints yesterday itself and one more thing which i found is /var/www/cgi-bin wont holding any wsgi_script so i copied it from one of my packstack node and make it working.I am no more seeing placement issue.

nakul_redhat gravatar imagenakul_redhat ( 2017-04-28 05:05:38 -0500 )edit