Instance Launch failed

asked 2017-04-23 07:01:09 -0600

vikash gravatar image

while launching instance creation getting filed with errors which get printed at compute node and controller node : Message No valid host was found. There are not enough hosts available.

Controller node: /var/log/nova/nova-scheduler.log 2017-04-23 12:41:36.721 13396 INFO nova.scheduler.host_manager [req-549f5a0f-93de-4ec3-ba31-0b6de7a45798 - - - - -] Successfully synced instances from host 'compute1'. 2017-04-23 12:42:32.051 13396 ERROR nova.scheduler.client.report [req-77925e5f-c8d4-4b59-af03-42a8b48fe260 - - - - -] Failed to retrieve filtered list of resource providers from placement API for filters {'resources': 'DISK_GB:1,MEMORY_MB:4096,VCPU:1'}. Got 404: <html><head> <title>404 Not Found</title> </head><body>

Not Found

The requested URL /placement/resource_providers was not found on this server.

</body></html> . 2017-04-23 12:42:32.052 13396 INFO nova.filters [req-77925e5f-c8d4-4b59-af03-42a8b48fe260 - - - - -] Filter RetryFilter returned 0 hosts

compute node: /var/log/nova/nova-compute.log 2017-04-23 17:29:27.005 15808 ERROR nova.scheduler.client.report [req-010bdd3d-1087-47c3-b16a-eaf47768a06b - - - - -] Failed to create resource provider record in placement API for UUID 85d3552b-034c-436f-9324-260cf300a980. Got 404: <html><head> <title>404 Not Found</title> </head><body>

Not Found

The requested URL /placement/resource_providers was not found on this server.

</body></html> . 2017-04-23 17:29:27.006 15808 WARNING nova.scheduler.client.report [req-010bdd3d-1087-47c3-b16a-eaf47768a06b - - - - -] Unable to refresh my resource provider record 2017-04-23 17:29:27.115 15808 INFO nova.compute.resource_tracker [req-010bdd3d-1087-47c3-b16a-eaf47768a06b - - - - -] Final resource view: name=compute1 phys_ram=98291MB used_ram=512MB phys_disk=1389GB used_disk=0GB total_vcpus=24 used_vcpus=0 pci_stats=[]

edit retag flag offensive close merge delete

Comments

I'm having the same issue - it's something to do with 404's being generated on the placement API endpoint.

AndyWojo gravatar imageAndyWojo ( 2017-05-17 18:44:29 -0600 )edit

I have the same issue

juangallego gravatar imagejuangallego ( 2017-05-30 15:46:25 -0600 )edit

I also hit the same issue on Ocata

Harsh 5GNR gravatar imageHarsh 5GNR ( 2017-08-28 15:12:44 -0600 )edit

I found the solution. The packstack installation of Ocata on Centos 7 sets the wrong value for [placement] API. Check your auth_url. It should be auth_url=http://<controller_ip>:35357/v3

Harsh 5GNR gravatar imageHarsh 5GNR ( 2017-08-29 09:12:22 -0600 )edit