Ceilometer CLI command execution throws "requires authentication. (HTTP 401)" error:

asked 2017-04-21 00:10:29 -0600

prashr186 gravatar image

Hi , Ceilometer CLI command execution throws "requires authentication. (HTTP 401)" error: [root@localhost ceilometer(keystone_admin)]# ceilometer alarm-list The request you have made requires authentication. (HTTP 401) (Request-ID: req-bfcaab71-85d4-4c3f-ba98-6e5a941d1923)

openstack nova version: [root@localhost ceilometer(keystone_admin)]# nova-manage version Option "rpc_backend" from group "DEFAULT" is deprecated for removal. Its value may be silently ignored in the future. 14.0.3-1.el7

Regards, Prashanth R

edit retag flag offensive close merge delete

Comments

What are your credentials? You can see them by listing your OpenStack environment variables, export | grep OS_.

Bernd Bausch gravatar imageBernd Bausch ( 2017-04-21 21:21:39 -0600 )edit

Hi , The credentials are:

[root@localhost ~(keystone_admin)]# export | grep OS_ declare -x OS_AUTH_URL="http://172.16.1.100:5000/v2.0" declare -x OS_PASSWORD="02f97c5fd539438c" declare -x OS_REGION_NAME="RegionOne" declare -x OS_TENANT_NAME="admin" declare -x OS_USERNAME="admin"

Thanks,

prashr186 gravatar imageprashr186 ( 2017-04-23 23:04:58 -0600 )edit

Can you sucessfully obtain a token with these credentials? Use openstack token issue or, if you are on an older version of OpenStack, keystone token-get.

Are there any other commands, ceilometer or other CLIs, that work?

Bernd Bausch gravatar imageBernd Bausch ( 2017-04-24 07:16:01 -0600 )edit