Packstack fail to install OpenStack - Ocata - Could not find dependency Package[openstack-ceilometer-common] for File[/etc/pki/tls/private/ssl_amqp_ceilometer.key]

asked 2017-04-20 18:31:01 -0500

wowuor gravatar image

updated 2017-05-30 09:48:57 -0500

rbowen gravatar image

I am requesting kindly for assistance in determining

Could not find dependency Package[openstack-ceilometer-common] for File[/etc/pki/tls/private/ssl_amqp_ceilometer.key] at /var/tmp/packstack/ce5f7fc03bd34d4bb632a58d900e13e9/modules/packstack/manifests/ceilometer/rabbitmq.pp:14

error during a fresh install of Centos 7.3 and installing the latest Ocata.

ERROR : Error appeared during Puppet run: XX.XX.XX.XX_controller.pp
Error: Could not find dependency Package[openstack-ceilometer-common] for File[/etc/pki/tls/private/ssl_amqp_ceilometer.key] at /var/tmp/packstack/ce5f7fc03bd34d4bb632a58d900e13e9/modules/packstack/manifests/ceilometer/rabbitmq.pp:14

Detail log.

tar --dereference -cpzf - aodh apache ceilometer certmonger cinder concat firewall glance gnocchi heat horizon inifile ironic keystone magnum manila memcached mongodb mysql neutron nova nssdb openstack openstacklib oslo packstack panko rabbitmq redis remote rsync sahara ssh stdlib swift sysctl tempest trove vcsrepo vswitch xinetd | ssh -o StrictHostKeyChecking=no -o UserKnownHostsFile=/dev/null root@XX.XX.XX.XX tar -C /var/tmp/packstack/ce5f7fc03bd34d4bb632a58d900e13e9/modules -xpzf -
2017-04-20 16:40:04::ERROR::run_setup::1027::root:: Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 1022, in main
    _main(options, confFile, logFile)
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 678, in _main
    runSequences()
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 645, in runSequences
    controller.runAllSequences()
  File "/usr/lib/python2.7/site-packages/packstack/installer/setup_controller.py", line 81, in runAllSequences
    sequence.run(config=self.CONF, messages=self.MESSAGES)
  File "/usr/lib/python2.7/site-packages/packstack/installer/core/sequences.py", line 109, in run
    step.run(config=config, messages=messages)
  File "/usr/lib/python2.7/site-packages/packstack/installer/core/sequences.py", line 50, in run
    self.function(config, messages)
  File "/usr/lib/python2.7/site-packages/packstack/plugins/puppet_950.py", line 214, in apply_puppet_manifest
    wait_for_puppet(currently_running, messages)
  File "/usr/lib/python2.7/site-packages/packstack/plugins/puppet_950.py", line 128, in wait_for_puppet
    validate_logfile(log)
  File "/usr/lib/python2.7/site-packages/packstack/modules/puppet.py", line 107, in validate_logfile
    raise PuppetError(message)
PuppetError: Error appeared during Puppet run: XX.XX.XX.XX_controller.pp
Error: Could not find dependency Package[openstack-ceilometer-common] for File[/etc/pki/tls/private/ssl_amqp_ceilometer.key] at /var/tmp/packstack/ce5f7fc03bd34d4bb632a58d900e13e9/modules/packstack/manifests/ceilometer/rabbitmq.pp:14
You will find full trace in log /var/tmp/packstack/20170420-163411-neyF_d/manifests/XX.XX.XX.XX_controller.pp.log
edit retag flag offensive close merge delete

Comments

You should tag your question with RDO; this increases the changes the Packstack team gets interested (I did that for you). Then you could use yum list to check if openstack-ceilometer-common is found, and if not, why not. Also look for more info in the log file mentioned in the very last line.

Bernd Bausch gravatar imageBernd Bausch ( 2017-04-21 21:17:46 -0500 )edit

I also faced the same issue with same version of openstack.

Installing the openstack-ceilometer-common did not make any difference.

hiteshingole gravatar imagehiteshingole ( 2017-04-22 02:31:33 -0500 )edit

So, is there anything in the referenced log file?

Bernd Bausch gravatar imageBernd Bausch ( 2017-04-24 07:22:20 -0500 )edit

I have the same issue and here is the referenced log, can't tell anything new/different in the log that would help. I tried this today, so seems the issue is still there in latest codebase. Can't see anything in the log mentioned and can't post the log here as it is too big a file.

Kamlesh gravatar imageKamlesh ( 2017-06-04 17:34:27 -0500 )edit