Ask Your Question
0

physical_network 'physnet2' unknown for VLAN provider network.

asked 2017-04-19 11:39:13 -0500

m0nk3y3dd gravatar image

Hello I'm using ubuntu with openstack liberty. I'm having issues while configuring my vlans Here is the output of /etc/neutron/plugin.ini [ml2_type_vlan] network_vlan_ranges = physnet2

But when I run the following command I get [centos@localhost ~(keystone_admin)]$ neutron net-create management --shared --tenant_id core --provider:network_type vlan --provider:segmentation_id 1114 --provider:physical_network physnet2 Invalid input for operation: physical_network 'physnet2' unknown for VLAN provider network.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2017-04-20 03:31:40 -0500

eblock gravatar image

Hi, you need a mapping between "physnet" and your actual physical network:

control1:~ # grep physical_interface_mappings /etc/neutron/plugins/ml2/linuxbridge_agent.ini
physical_interface_mappings = physnet1:bond0

and you need to define a vlan range:

control1:~ # grep network_vlan_ranges /etc/neutron/plugins/ml2/ml2_conf.ini
network_vlan_ranges = physnet1:1100:1199

Hope this helps!

edit flag offensive delete link more

Comments

Thank you SO much!!! To think, I've been running around looking at complicated guides when all it took were these small steps. Particularly the vlan range setup that you mentioned for ml2_conf.ini

keyn0te gravatar imagekeyn0te ( 2019-02-14 10:13:21 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2017-04-19 11:39:13 -0500

Seen: 1,684 times

Last updated: Apr 20 '17