Ask Your Question
0

python3-systemd,libvirt-clients, libvirt-daemon-system & syslinux-utils package locate failed on latest devstack branches [closed]

asked 2017-04-15 12:51:59 -0500

Suresh Nagaraj gravatar image

updated 2017-04-16 03:19:20 -0500

I fixed the python3-systemd error by removing the package from the file files/debs/general.

But after this I am finding new ./stack.sh errors.

+functions-common:apt_get:1104
sudo DEBIAN_FRONTEND=noninteractive http_proxy= https_proxy= no_proxy= apt-get --option Dpkg::Options::=--force-confold --assume-yes install libvirt-clients libvirt-daemon-system libvirt-dev

Reading package lists... Done

Building dependency tree

Reading state information... Done

E: Unable to locate package libvirt-clients

E: Unable to locate package libvirt-daemon-system

I have commented this changes in the file lib/nova_plugins/functions-libvirt

@@ -64,8 +64,8 @@ function install_libvirt {

     install_package qemu-system

     if [[ ${DISTRO} == "xenial" ]]; then

        install_package libvirt-bin libvirt-dev
  • else
  • install_package libvirt-clients libvirt-daemon-system libvirt-dev

+# else

+# install_package libvirt-clients libvirt-daemon-system libvirt-dev

     fi

Please let me know if this is going to break anything.

Hi All,

From yesterday after enabling reclone, I am facing ./stack.sh errors(E: Unable to locate package python3-systemd) on latest devstack branches(master, newton & ocata). Error logs below. I am using Ubuntu 14.04 LTS for installing devstack. Please help me how can fix this issue.

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

++functions-common:apt_get:1104
sudo DEBIAN_FRONTEND=noninteractive http_proxy= https_proxy= no_proxy= apt-get --option Dpkg::Options::=--force-confold --assume-yes install apache2 apache2-dev bc bridge-utils bsdmainutils curl g++ gcc gettext git graphviz iputils-ping libapache2-mod-proxy-uwsgi libffi-dev libjpeg-dev libmysqlclient-dev libpq-dev libssl-dev libxml2-dev libxslt1-dev libyaml-dev lsof openssh-server openssl pkg-config psmisc python2.7 python3-systemd python-dev python-gdbm python-systemd screen tar tcpdump unzip uuid-runtime wget wget zlib1g-dev libkrb5-dev libldap2-dev libsasl2-dev memcached python-mysqldb sqlite3 fping conntrack curl dnsmasq-base dnsmasq-utils ebtables gawk genisoimage iptables iputils-arping kpartx libjs-jquery-tablesorter libmysqlclient-dev parted pm-utils python-mysqldb socat sqlite3 sudo vlan cryptsetup genisoimage gir1.2-libosinfo-1.0 netcat-openbsd open-iscsi qemu-utils sg3-utils sysfsutils lvm2 open-iscsi qemu-utils thin-provisioning-tools acl dnsmasq-base ebtables haproxy iptables iputils-arping iputils-ping libmysqlclient-dev postgresql-server-dev-all python-mysqldb sqlite3 sudo vlan libpcre3-dev dstat gettext

Reading package lists... Done

Building dependency tree

Reading state information... Done

E: Unable to locate package python3-systemd

+functions-common:apt_get:1 exit_trap

+./stack.sh:exit_trap:488 local r=100

++./stack.sh:exit_trap:489 jobs -p

+./stack.sh:exit_trap:489 jobs=

+./stack.sh:exit_trap:492 [[ -n '' ]]

+./stack.sh:exit_trap:498 kill_spinner

+./stack.sh:kill_spinner:384 '[' '!' -z '' ']'

+./stack.sh:exit_trap:500 [[ 100 -ne 0 ]]

+./stack.sh:exit_trap:501 echo 'Error on exit'

Error on exit

+./stack.sh:exit_trap:502 generate-subunit 1492277982 59 fail

./stack.sh: line 502: generate-subunit: command not found

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Thanks -Suresh

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by Suresh Nagaraj
close date 2017-04-23 12:46:00.862692

Comments

I also met the same problem as follow:

2017-04-16 05:55:51.414 | Reading package lists...

2017-04-16 05:55:51.761 | Building dependency tree...

2017-04-16 05:55:51.762 | Reading state information...

2017-04-16 05:55:51.852 | E: Unable to locate package python3-systemd

Need help!

lyn gravatar imagelyn ( 2017-04-16 20:21:25 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2017-04-23 12:45:46 -0500

Suresh Nagaraj gravatar image

Looks devstack is no more supported on Ubuntu 14.04 LTS. I dint see the same error on Ubuntu 16.04 LTS.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-04-15 12:51:59 -0500

Seen: 564 times

Last updated: Apr 23 '17