Ask Your Question
1

Mistral returns "Operation not allowed" with auth_enable=False

asked 2017-04-13 11:56:48 -0500

mattybrennan gravatar image

I'm running the provided mistral docker image, with a small custom configuration

[DEFAULT] 
rpc_backend = fake

[pecan]
auth_enable = False

All of the API calls return "Operation not allowed". Is there an authorization setting I'm missing?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-04-14 15:46:13 -0500

mattybrennan gravatar image

I got this working by creating a rabbitmq container and removing the custom config. It would be nice if it was able to run with "rpc_backend = fake" while trying to just test mistral out.

edit flag offensive delete link more

Comments

You should be able to use rpc_backend = fake. I think there was an issue with it recently but it was resolved. Generally the developers don't use it as it is too limited.

d0ugal gravatar imaged0ugal ( 2017-04-17 04:25:39 -0500 )edit
1

Also, if you use the start_mistral_rabbit_mysql.sh script (in https://github.com/openstack/mistral/...) it will create three containers - one for Mistral, one for rabbit and one for MySQL and it will connect them. This is generally the easiest way to try out Mistral.

d0ugal gravatar imaged0ugal ( 2017-04-17 04:30:36 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-04-13 11:50:53 -0500

Seen: 66 times

Last updated: Apr 14 '17