Ask Your Question
0

The request you have made requires authentication. (HTTP 401)

asked 2017-04-12 09:18:25 -0500

anonymous user

Anonymous

Running: openstack project create --domain default --description "Service Project" service --os-username admin

Gets this error: The request you have made requires authentication. (HTTP 401) (Request-ID: req-38d87c30-9a4c-4c3a-81a4-c3e7783f8f1b)

With this log output:2017-04-12 09:45:44.387 2021 INFO keystone.common.wsgi [req-eaeaf3b7-0527-4f80-92d2-d62f5e4aecc1 - - - - -] GET http://172.16.x.x:35357/v3/ 2017-04-12 09:45:44.400 2026 INFO keystone.common.wsgi [req-c035710d-a3c0-4d83-9293-2f711fa24f9e - - - - -] POST http://172.16.x.x:35357/v3/auth/tokens 2017-04-12 09:45:44.459 2026 WARNING keystone.auth.core [req-c035710d-a3c0-4d83-9293-2f711fa24f9e - - - - -] Could not find domain: Default. 2017-04-12 09:45:44.460 2026 WARNING keystone.common.wsgi [req-c035710d-a3c0-4d83-9293-2f711fa24f9e - - - - -] Authorization failed. The request you have made requires authentication. from 172.16.x.x 2017-04-12 09:47:29.542 2021 INFO keystone.common.wsgi [req-32f19bcd-8a9f-4ad4-8afe-7dbd547bde00 - - - - -] GET http://172.16.x.x:35357/v3/ 2017-04-12 09:47:29.555 2018 INFO keystone.common.wsgi [req-38d87c30-9a4c-4c3a-81a4-c3e7783f8f1b - - - - -] POST http://172.16.x.x:35357/v3/auth/tokens 2017-04-12 09:47:29.561 2018 WARNING keystone.auth.core [req-38d87c30-9a4c-4c3a-81a4-c3e7783f8f1b - - - - -] Could not find domain: Default. 2017-04-12 09:47:29.562 2018 WARNING keystone.common.wsgi [req-38d87c30-9a4c-4c3a-81a4-c3e7783f8f1b - - - - -] Authorization failed. The request you have made requires authentication. from 172.16.x.x 2017-04-12 09:53:03.732 2021 INFO keystone.common.wsgi [req-6180af73-6c1a-40b6-865b-7ada9e3d1886 - - - - -] GET http://172.16.x.x:35357/v3/ 2017-04-12 09:53:03.747 2022 INFO keystone.common.wsgi [req-348997ec-1a2c-4a8f-86ff-3ec5e1c89951 - - - - -] POST http://172.16.x.x:35357/v3/auth/tokens 2017-04-12 09:53:03.754 2022 WARNING keystone.auth.core [req-348997ec-1a2c-4a8f-86ff-3ec5e1c89951 - - - - -] Could not find domain: Default. 2017-04-12 09:53:03.754 2022 WARNING keystone.common.wsgi [req-348997ec-1a2c-4a8f-86ff-3ec5e1c89951 - - - - -] Authorization failed. The request you have made requires authentication. from 172.16.x.x

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-04-12 09:28:36 -0500

Set shell variables as shown in the installation guide before using Keystone.

edit flag offensive delete link more

Comments

I exported the shell variables but still get that error. Is there a command I can run to tell it to use a certain credential? --password-prompt maybe?

md_network_engineer gravatar imagemd_network_engineer ( 2017-04-12 09:41:47 -0500 )edit

I just saw "Could not find domain: Default" in your log output. I woud say you need to look into you keystone setup.

Bernd Bausch gravatar imageBernd Bausch ( 2017-04-12 10:18:21 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-04-12 09:18:25 -0500

Seen: 3,223 times

Last updated: Apr 12 '17