packstack Ocata --allinone error:

asked 2017-04-10 13:04:10 -0600

stackattack gravatar image

I receive this error when running allinone on a fresh minimal install CentOS Linux release 7.3.1611 (Core) I'm following this doc step-by-step: https://www.rdoproject.org/install/quickstart/ (https://www.rdoproject.org/install/qu...) The error occurs after step 3: "packstack --allinone"

* "Error: Failed to apply catalog" *

tail -f /var/tmp/packstack/20170407-160121-81CAUG/openstack-setup.log

PuppetError: Error appeared during Puppet run: 10.101.23.50_controller.pp Error: /usr/sbin/ntpdate 10.101.23.30 returned 1 instead of one of [0] You will find full trace in log /var/tmp/packstack/20170407-160121-81CAUG/manifests/10.101.23.50_controller.pp.log  

2017-04-07 17:09:08::INFO::shell::94::root:: [10.101.23.50] Executing script: rm -rf /var/tmp/packstack/832b7dfb937b46c5b24c337850e0cc6f

tail /var/tmp/packstack/20170407-160121-81CAUG/manifests/10.101.23.50_controller.pp.log

Error: Failed to apply catalog: Command: 'openstack ["flavor", "list", "--quiet", "--format", "csv", ["--long", "--all"]]' has been running for more than 40 seconds (tried 4, for a total of 170 seconds)
edit retag flag offensive close merge delete

Comments

Could you give more logs ?

tail -100 /var/tmp/packstack/20170407-160121-81CAUG/manifests/10.101.23.50_controller.pp.log

Rajesh Ramachandran gravatar imageRajesh Ramachandran ( 2017-04-11 03:18:54 -0600 )edit

Hi Rajesh. Thank you. I don't believeI can attach many lines here. I grepped for "fail".

Error: /Stage[main]/Packstack::Chrony/Exec[ntpdate]/returns: change from notrun to 0 failed: /usr/sbin/ntpdate 10.101.23.30 returned 1 instead of one of [0]

Notice: /Stage[main]/Packstack::Chrony/Service[

stackattack gravatar imagestackattack ( 2017-04-11 10:52:50 -0600 )edit

I think it's NTP related. That was the first thing to fail.

stackattack gravatar imagestackattack ( 2017-04-11 10:53:12 -0600 )edit

Great, Glad that you found the issue !!

Rajesh Ramachandran gravatar imageRajesh Ramachandran ( 2017-04-11 23:42:13 -0600 )edit

I reran after fixing DATE/TIME and have new errors.

... Discovering ip protocol version [ DONE ] ... Installing time synchronization via NTP [ DONE ] ... 10.101.23.50_controller.pp: [ ERROR ] Applying Puppet manifests [ ERROR ]

stackattack gravatar imagestackattack ( 2017-04-12 11:20:39 -0600 )edit

ERROR : Error appeared during Puppet run: 10.101.23.50_controller.pp Error: /usr/sbin/ntpdate 10.101.23.30 returned 1 instead of one of [0] Do I need to setup NTP server locally prior prior to running? I thought packstack did that.

stackattack gravatar imagestackattack ( 2017-04-12 11:26:16 -0600 )edit

Another iteration. tail /var/log/messages

Failed to start OpenStack Nova Scheduler Server.
stackattack gravatar imagestackattack ( 2017-04-12 16:58:55 -0600 )edit

I would check if NTPD is already running, In that case you can edit the answer file and leave "CONFIG_NTP_SERVERS" to be blank. If not, please check if CONFIG_NTP_SERVERS has the right pools of ntp servers.

Rajesh Ramachandran gravatar imageRajesh Ramachandran ( 2017-04-13 00:46:57 -0600 )edit

For nova scheduler issue, what is the output of "systemctl status openstack-nova-scheduler". Also, does the scheduler logs has any error messages ?

Rajesh Ramachandran gravatar imageRajesh Ramachandran ( 2017-04-13 00:47:46 -0600 )edit

Thanks. ntpd is not running. there is no "CONFIG_NTP_SERVERS" block in my answer file.

stackattack gravatar imagestackattack ( 2017-04-14 12:52:16 -0600 )edit

[root@c7m2 ~]# systemctl status openstack-nova-scheduler -l ● openstack-nova-scheduler.service - OpenStack Nova Scheduler Server Loaded: loaded (/usr/lib/systemd/system/openstack-nova-scheduler.service; disabled; vendor preset: disabled) Active: activating (start) since Fri 2017-04-14 ...

stackattack gravatar imagestackattack ( 2017-04-14 12:52:59 -0600 )edit

Apr 14 10:51:30 http://c7m2.lab.siliconmechanics.com systemd[1]: openstack-nova-scheduler.service holdoff time over, scheduling restart. Apr 14 10:51:30 http://c7m2.lab.siliconmechanics.com systemd[1]: Starting OpenStack Nova Scheduler Server...

stackattack gravatar imagestackattack ( 2017-04-14 12:53:06 -0600 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2019-01-19 05:52:02 -0600

amer.hwitat gravatar image

well it's the VM is very slow and have trouble with RAM and CPU ... I have this problem now on RH OSP 14

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-04-10 13:04:10 -0600

Seen: 1,578 times

Last updated: Apr 10 '17