neutron error when I try to create an instance

asked 2017-04-10 02:21:38 -0500

masber gravatar image

updated 2017-04-11 21:05:07 -0500

Hi,

I am getting an error when I try to create an instance. This is for a new openstack ocata installation with kolla-ansible.

neutron server logs:

2017-04-10 18:11:19.088 23 ERROR neutron.plugins.ml2.managers [req-41aea23f-c321-4584-8e5a-ef0495010a73 - - - - -] Failed to bind port f103ad11-dd2c-4d83-be2c-4329726df8c5 on host nova-compute.localdomain for vnic_type normal using segments [{'segmentation_id': 92, 'physical_network': None, 'id': u'ba1db3c0-5f78-431d-898a-a3eefbf10de4', 'network_type': u'vxlan'}]

ml2_conf.ini on nova-compute (compute node):

[ml2]
type_drivers = flat,vlan,vxlan
tenant_network_types = vxlan
mechanism_drivers = openvswitch,l2population

[ml2_type_vlan]
network_vlan_ranges =

[ml2_type_flat]
flat_networks = physnet1

[ml2_type_vxlan]
vni_ranges = 1:1000
vxlan_group = 239.1.1.1

[securitygroup]
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver

[agent]
tunnel_types = vxlan
l2_population = true
arp_responder = true

[ovs]
bridge_mappings = physnet1:br-ex
ovsdb_connection = tcp:129.94.72.54:6640
local_ip = 10.1.0.12

ml2_conf.ini on controll node:

[ml2]
type_drivers = flat,vlan,vxlan
tenant_network_types = vxlan
mechanism_drivers = openvswitch,l2population

[ml2_type_vlan]
network_vlan_ranges =

[ml2_type_flat]
flat_networks = physnet1

[ml2_type_vxlan]
vni_ranges = 1:1000
vxlan_group = 239.1.1.1

[securitygroup]
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver

[agent]
tunnel_types = vxlan
l2_population = true
arp_responder = true

[ovs]
bridge_mappings = physnet1:br-ex
ovsdb_connection = tcp:129.94.72.51:6640
local_ip = 129.94.72.51

open vswitch agent is up:

[root@kolla ~]# openstack network agent list
+-------------------------------+--------------------+-------------------------------+-------------------+-------+-------+---------------------------+
| ID                            | Agent Type         | Host                          | Availability Zone | Alive | State | Binary                    |
+-------------------------------+--------------------+-------------------------------+-------------------+-------+-------+---------------------------+
| 55d0c864-d42d-                | L3 agent           | openstack-                    | nova              | True  | UP    | neutron-l3-agent          |
| 47ee-b455-b8045d181721        |                    | controller.localdomain        |                   |       |       |                           |
| 635a3279-e653-4394-a44f-      | DHCP agent         | openstack-                    | nova              | True  | UP    | neutron-dhcp-agent        |
| 0172be7a6e1a                  |                    | controller.localdomain        |                   |       |       |                           |
| c93a6735-1623-4f38-b889-6cc72 | Metadata agent     | openstack-                    | None              | True  | UP    | neutron-metadata-agent    |
| fa07cb3                       |                    | controller.localdomain        |                   |       |       |                           |
| cc82c6c6-8d9f-4c3d-           | Open vSwitch agent | openstack-                    | None              | True  | UP    | neutron-openvswitch-agent |
| bb72-50783044524f             |                    | controller.localdomain        |                   |       |       |                           |
+-------------------------------+--------------------+-------------------------------+-------------------+-------+-------+---------------------------+

Could someone please help me to understand what the issue is?

thank you very much

edit retag flag offensive close merge delete

Comments

The problem is ill-configured Neutron. The port that connects the instance to the network can't be mapped to physical network objects. I don't know how this works in Kolla, but can you post the complete message? And your ML2 configuration?

Bernd Bausch gravatar imageBernd Bausch ( 2017-04-10 03:28:54 -0500 )edit

hi @Bernd Bausch I edited my question with more trace logs,

masber gravatar imagemasber ( 2017-04-10 19:24:55 -0500 )edit

sorry for more questions. Are you sure the OVS agent is running? Run openstack network agent list to check. Also check the openvswitch-agent log file on the compute host(s).

Bernd Bausch gravatar imageBernd Bausch ( 2017-04-11 02:13:29 -0500 )edit

@Bernard Bausch Yes the OVS agent is up.

masber gravatar imagemasber ( 2017-04-11 20:55:32 -0500 )edit
1

Neutron wants to bind the port on host nova-compute.localdomain, but this host doesn't have an openvswitch agent. If this host exists and the agent is running there, check its log file. You may find it's incapable of communicating over the message queue. Often this is due to wrong clock settings.

Bernd Bausch gravatar imageBernd Bausch ( 2017-04-11 20:58:58 -0500 )edit