Ask Your Question
1

Horizon dashboard runs without styles

asked 2017-04-07 10:29:56 -0500

hamza.elalaoui gravatar image

updated 2017-04-13 11:21:43 -0500

Hi everyone, I'am installing Openstack Ocata release on Ubuntu 16.04 LTS on multiple nodes architecture.

I had followed the official documentation provided by the openstack community. Everything is going OK until now, except the Horizon Dashboard that looks messy and not organized because the styles and scss components are not loaded in the browser.

It seems that the styles or the javascripts do not work properly under my environment. By the way, the web apache2 server run correctly and mod-wsgi works too.

Can somebody help me with this issue ?? Which file should I edit to make the design look normal ?? Do i have to install new packages ?? or should i create links so that scss styles can be loaded to the browser ??

Thanks in advance

image description

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2017-04-13 04:20:13 -0500

Laurent_bcn gravatar image

updated 2017-04-13 04:28:33 -0500

Try to go to the openstack-dahsboard directory and then run commands:

./manage.py collectstatic

./manage.py compress

service apache2 reload

Have a look also to /var/log/apache2/error.log

Try to catch if you got some 404 errors in /var/log/apache2/access.log

edit flag offensive delete link more

Comments

Tried but doesnt solv the prblem, and for the errors there was no 404 error in the access log file :( when i run these commands i get : This will overwrite existing files ! ..... ... Compressing done Compressed 7 block from 3 template for 3 context

hamza.elalaoui gravatar imagehamza.elalaoui ( 2017-04-13 11:20:30 -0500 )edit

So ok could you please check this :

in the file /etc/apache2/conf-enabled/openstack-dashboard.conf :

Check that the Alias /static and Alias /horizon/static point to a directory that exists and contains those sub-directories:

app auth dashboard framework horizon js scss themes

Laurent_bcn gravatar imageLaurent_bcn ( 2017-04-13 11:32:03 -0500 )edit

the uncommented Alias /static and Alias /horizon/static werent pointing to those directories, so i checked the commented Alias /static and Alias /horizon/static and they were pointing to those directories. After uncommenting and reloading the apache2 service nothing changed :(

hamza.elalaoui gravatar imagehamza.elalaoui ( 2017-04-14 03:10:17 -0500 )edit

2' tips:

1- your static-dir (ie /usr/share/openstack-dashboard/openstack_dashboard/static/ ) must finish with an end '/'

2 - you need to check also that static-dir is authorized in the openstack-dashboard.conf :

<Directory static-dir > 

  Require all granted

</Directory>
Laurent_bcn gravatar imageLaurent_bcn ( 2017-04-14 03:31:04 -0500 )edit

Thank you Laurent_bcn, the ubuntu theme has chown up for the first time !! This is the right answer

hamza.elalaoui gravatar imagehamza.elalaoui ( 2017-04-14 04:10:12 -0500 )edit
0

answered 2017-04-10 04:20:53 -0500

kibnelbachyr gravatar image

updated 2017-04-10 09:50:05 -0500

Did you have some kind of "Internal server ERRORS" before?

Can you verify if you have some themes already installed in /usr/share/openstack-dashboard/openstack_dashboard/themes ?!

edit flag offensive delete link more

Comments

I didn't have server errors, the web apache server run correctly and the libapache2-mod-wsgi is already installed.The themes installed are those installed by default (Ubuntu, material, default) I've tried to chnge the theme but it dont solve the problem!! Is the web server compatible with the styles

hamza.elalaoui gravatar imagehamza.elalaoui ( 2017-04-10 10:01:28 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-04-07 09:31:12 -0500

Seen: 123 times

Last updated: Apr 13