Ask Your Question
2

I am able to Ping but not able to SSH in to the VMs

asked 2014-01-15 05:03:02 -0500

Nivas gravatar image

updated 2014-01-15 05:25:40 -0500

Hi All, I am able to ping my VMs but i am unable to do SSH. the same VM image works fine inside VirtualBox. I can start/stop/reboot/resize my images with out any issues but while doing ssh, i am getting

"ssh: connect to host 10.0.0.9 port 22: Connection refused"

There is also no valuable log in compute.log too. may i know the issue could be?

Here are my details,

OpenstackHavanna with keystone,glance, nova on 2 centos machines Image : raw qcow2

ssh and ping rules are added by default to the security group

Thanks in advance,

edit retag flag offensive close merge delete

Comments

Any success NIvas?

Same problem with Juno using image from http://cloud.centos.org/centos/7/devel/ nmap only shows port 21(ftp) has available AND nova root-password server_id ERROR (HTTPNotImplemented): Unable to set password on instance

francois gravatar imagefrancois ( 2015-01-29 10:44:10 -0500 )edit

6 answers

Sort by ยป oldest newest most voted
1

answered 2014-01-15 21:30:07 -0500

huwei-xtu gravatar image

At first you must make sure the attached security group has added the ssh port(22).

Then, you can use "telnet ip_addr 22" to check if you can access ssh port, at most time, if you can access this port, means you have start the ssh service.

However, the easiest way is use "nova get-vnc-console instance_id novnc" to connect the instance, the precondition is you know the password and can log in.

edit flag offensive delete link more
1

answered 2015-03-11 00:53:02 -0500

amitabh sinha gravatar image

if you are getting this debug message when you trying to do ssh in one of the vm using ssh i key.pem ubuntu@ip

debug1: sending SSH2_MSG_KEX_ECDH_INIT debug1: expecting SSH2_MSG_KEX_ECDH_REPLY Connection closed by 192.168.1.122

Then you better set your MTU TO 1400 . soln:- using sudo ip link set eth0 mtu 1400.

IT WORKED FOR ME!!

edit flag offensive delete link more
0

answered 2015-08-12 04:16:06 -0500

sankalp82 gravatar image

I have same problem But I change MTU !!! I have change MTU from 1500 --> 1700 !! Now its work !!!

edit flag offensive delete link more
0

answered 2014-01-15 05:13:02 -0500

YefimG gravatar image

Make sure SSH server is running on the VM. Try to make a temporary user with password so you can login with console and make sure SSH server is ok. Also make sure security rules allow TCP connections.

edit flag offensive delete link more

Comments

how to check if ssh server is running in VM? Could you please explain how to do that? yes, security rules allow TCP connections.

Nivas gravatar imageNivas ( 2014-01-15 05:21:21 -0500 )edit
0

answered 2014-01-15 14:16:46 -0500

amber_nic gravatar image

You can access your vm via Horizon/Console or through VNC. In the latter case scan first on which ports of the compute node are up (i.e.: 5900, 5901, etc). Then you can connect to the instance, log in and check if the ssh service is up.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2014-01-15 05:03:02 -0500

Seen: 10,515 times

Last updated: Mar 11 '15