Ask Your Question

devstack no hosts available

asked 2017-04-04 09:54:01 -0500

ge0rgi gravatar image

I am trying to run a devstack installation from the stable/ocata branch. At first I got the following error No hosts found to map to cell, exiting” I solved it by adding enable_service n-cell to my local.conf, so now the file looks like this

enable_service n-cell

The installation completed successfully, however when I try to create new cirros vm I am getting the following error:

 No valid host was found. There are not enough hosts available

From the screen session I see that n-cond n-cell-region n-cell-child n-sch n-cauth and n-cpu are running. In the scheduler log I found the following error

2017-04-04 15:47:53.219 DEBUG nova.filters [req-7ae99e00-ddcc-492f-b061-805aa4314cee admin 
admin] Starting with 0 host(s) from (pid=30739) get_filtered_objects /opt/stack/nova/no
2017-04-04 15:47:53.220 INFO nova.filters [req-7ae99e00-ddcc-492f-b061-805aa4314cee admin a
dmin] Filter RetryFilter returned 0 hosts

In nova-cells.conf I see the following filters are enabled:

scheduler_default_filters = RetryFilter,AvailabilityZoneFilter,RamFilter,DiskFilter,ComputeFilter,ComputeCapabilitiesFilter,ImagePropertiesFilter,ServerGroupAntiAffinityFilter,ServerGroupAffinityFilter,SameHostFilter,DifferentHostFilter

I don't see anything wrong in the config, the only thing that bothers me is enable_service n-cell, because I never needed it to run devstack. Any ideas why the scheduler is starting with 0 hosts

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted

answered 2017-04-05 22:25:16 -0500

macsz gravatar image

Keep in mind that by using enable_service n-cell you switch to the legacy cells v1 implementation ([1]).

Can you verify that all nova services are up and running by executing: nova service-list command?

Also, in Ocata we introduced a new service called placement. You should also have it up and running (it will not show on the list returned by nova service-list command). If in screen session you do not see a tab named "placement-api" this is the issue that you can investigate further and try adding ENABLED_SERVICES+=,placement-api to devstack conf.

  • [1] (
edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2017-04-04 09:54:01 -0500

Seen: 517 times

Last updated: Apr 05 '17