Got "Could not find package nrpe" error when perform packstack installatoin [closed]

asked 2014-01-15 03:24:49 -0600

anonymous user

Anonymous

updated 2014-01-17 19:31:03 -0600

smaffulli gravatar image

When I tried to deploy multiple nodes via packstack got error like below. Any body has idea about it?

SequenceError: Error appeared during Puppet run: <IP>_nagios_nrpe.pp
Error: Could not find package nrpe
You will find full trace in log /var/tmp/packstack/20140115-165620-8SM0pg/manifests/<IP>_nagios_nrpe.pp.log

2014-01-15 17:01:50::INFO::shell::78::root:: <IP> Executing script:
rm -rf /var/tmp/packstack/ef205ef65f1349ceaccb753675df70af
2014-01-15 17:01:52::INFO::shell::78::root:: <IP> Executing script:
rm -rf /var/tmp/packstack/5ac2332c5eb04d0eaadc1a069af0f9cc
[root@controller /]# /var/tmp/packstack/20140115-165620-8SM0pg/manifests/<IP>_nagios_nrpe.pp.log
-bash: /var/tmp/packstack/20140115-165620-8SM0pg/manifests/<IP>_nagios_nrpe.pp.log: Permission denied
[root@controller /]# more /var/tmp/packstack/20140115-165620-8SM0pg/manifests/<IP>_nagios_nrpe.pp.log
Warning: Could not retrieve fact fqdn
Warning: Unrecognised escape sequence '\[' in file /var/tmp/packstack/ef205ef65f1349ceaccb753675df70af/manifests/<IP>_nagios_nrpe.pp at line 33
Warning: Unrecognised escape sequence '\]' in file /var/tmp/packstack/ef205ef65f1349ceaccb753675df70af/manifests/<IP>_nagios_nrpe.pp at line 33
Notice: Compiled catalog for controller in environment production in 0.35 seconds
Error: Could not find package nrpe
Error: /Stage[main]/Main/Package[nrpe]/ensure: change from absent to present failed: Could not find package nrpe
Notice: /Stage[main]/Main/File[/etc/nagios/nrpe.cfg]: Dependency Package[nrpe] has failures: true
Warning: /Stage[main]/Main/File[/etc/nagios/nrpe.cfg]: Skipping because of failed dependencies
Notice: /Stage[main]/Nagios_configs/File_line[df_var]: Dependency Package[nrpe] has failures: true
Warning: /Stage[main]/Nagios_configs/File_line[df_var]: Skipping because of failed dependencies
Notice: /Stage[main]/Nagios_configs/File_line[load5]: Dependency Package[nrpe] has failures: true
Warning: /Stage[main]/Nagios_configs/File_line[load5]: Skipping because of failed dependencies
Notice: /Stage[main]/Nagios_configs/File_line[allowed_hosts]: Dependency Package[nrpe] has failures: true
Warning: /Stage[main]/Nagios_configs/File_line[allowed_hosts]: Skipping because of failed dependencies
Notice: /Stage[main]/Main/Service[nrpe]: Dependency Package[nrpe] has failures: true
Warning: /Stage[main]/Main/Service[nrpe]: Skipping because of failed dependencies
edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by larsks
close date 2014-04-03 13:52:36.603160

Comments

failed dependency. Please edit your question and specify the OS version and the yum repositories you're using.

smaffulli gravatar imagesmaffulli ( 2014-01-17 19:31:43 -0600 )edit

If you're installing on RHEL, have you followed the instructions at http://openstack.redhat.com/Repositories?

larsks gravatar imagelarsks ( 2014-01-18 13:12:37 -0600 )edit

Ping. Following up ... any progress on this?

rbowen gravatar imagerbowen ( 2014-03-06 14:21:28 -0600 )edit