Ask Your Question

Problem on setting up Ceilometer

asked 2014-01-15 02:48:12 -0500

RBK gravatar image


I am trying to install and configured ceilometer in my env.

I have added openstack-ceilometer-api, openstack-ceilometer-central and openstack-ceilometer-collector on controller node, and added openstack-ceilometer-compute on compute node.

But there is no output when executing "ceilometer meter-list" on controller node. Any idea?

I checked on the log on both controller and compute nodes, and only able to find the error in /var/log/ceilometer on compute node. But I am not sure how to resolve. probably there is some config problem in /etc/ceilometer/ceilomter.conf.

2014-01-15 16:46:13.934 26780 ERROR ceilometer.openstack.common.rpc.impl_qpid [-] Unable to connect to AMQP server: [Errno 111] ECONNREFUSED. Sleeping 60 seconds

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2014-03-17 05:43:22 -0500

Hasina gravatar image

you need to ensure you give the rabbit_host ip and the pwd correctly in ur ceilometer.conf file on your controller node.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2014-01-15 02:48:12 -0500

Seen: 291 times

Last updated: Mar 17 '14