Ask Your Question
0

Notifying alarm gets response: 403 AccessDenied.

asked 2017-04-03 02:03:13 -0500

AB239 gravatar image

Hello,

I am working on autoscaling with HEAT+ AODH + CEILOMETER. Here is the alarm list:

aodh alarm list
+-------------------------+-----------+--------------------------+-------+----------+---------+
| alarm_id                | type      | name                     | state | severity | enabled |
+-------------------------+-----------+--------------------------+-------+----------+---------+
| 887430c0-dc40-429b-9769 | threshold | my_stack-cpu_alarm_high- | alarm | low      | True    |
| -39311f360f35           |           | k4kgwps5mbpp             |       |          |         |
+-------------------------+-----------+--------------------------+-------+----------+---------+

Alarm is getting generated correctly but scaling out isn't working. I am getting following error in aoth-notifier.log

2017-04-03 12:27:57.078 2969 INFO aodh.notifier.rest [-] Notifying alarm my_stack-cpu_alarm_high-k4kgwps5mbpp 887430c0-dc40-429b-9769-39311f360f35 with severity low from alarm to alarm with action SplitResult(scheme=u'http', netloc=u'controller:8000', path=u'/v1/signal/arn%3Aopenstack%3Aheat%3A%3A6e665ce96bfa4907ac24b694b94711ab%3Astacks%2Fmy_stack%2F9fa05df9-fb1f-4c28-8ee9-829f91d87b7d%2Fresources%2Fscaleup_policy', query=u'Timestamp=2017-04-03T06%3A16%3A30Z&SignatureMethod=HmacSHA256&AWSAccessKeyId=491dbec9b8db49d7b2ef4cab6d12943c&SignatureVersion=2&Signature=RN8U2dEBVRpKW4T9Z7g55yTBQO3pD3N8pO4VByjKxLM%3D', fragment='') because Remaining as alarm due to 1 samples outside threshold, most recent: 15.4217992288. request-id: req-a3ef1500-7e52-4d16-8fbd-9a6cad23ff0a 

   2017-04-03 12:27:57.120 2969 INFO aodh.notifier.rest [-] Notifying alarm <887430c0-dc40-429b-9769-39311f360f35> gets response: 403 AccessDenied.

It seems to me an authentication error but can't find the exact root cause. Please suggest what steps should I take to resolve this one and get auto-scaling working.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-04-03 04:11:50 -0500

AB239 gravatar image

Guys I got it working. At the time you get this error in aodh-notifier.log, do check your syslog file for same message and check lines above it. You will find something like this:

Apr  3 14:15:56 controller heat-api-cfn[1179]: 2017-04-03 14:15:56.889 1179 INFO heat.api.aws.ec2token [-] Authenticating with http://controller:5000/ec2tokens
Apr  3 14:15:56 controller heat-api-cfn[1179]: 2017-04-03 14:15:56.906 1179 INFO heat.api.aws.ec2token [-] AWS authentication failure.

Last line is the root cause of this problem. Now go to heat.conf and modify this:

[ec2authtoken]
auth_uri = http://controller:5000/v3

Adding v3 at the end of auth_uri solved my error. I am able to auto-scale now.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-04-03 02:03:13 -0500

Seen: 139 times

Last updated: Apr 03 '17