Ask Your Question
0

devstack [ERROR] Neutron did not start

asked 2017-03-31 18:27:44 -0500

dbrtnakswja gravatar image

2017-03-31 15:02:05.484 | ./stack.sh:1263:start_neutron_service_and_check
2017-03-31 15:02:05.485 | /home/stack/devstack/lib/neutron-legacy:487:test_with_retry
2017-03-31 15:02:05.485 | /home/stack/devstack/functions-common:2416:die
2017-03-31 15:02:05.908 | [ERROR] /home/stack/devstack/functions-common:2416 Neutron did not start
2017-03-31 15:02:07.117 | Error on exit

what can i do? please help

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2017-04-01 11:48:19 -0500

updated 2017-04-01 11:49:09 -0500

In my humble opinion, if you don't know what to do, don't use DevStack. It's for OpenStack developers and testers and assumes you know OpenStack inside-out. While it's an easy way to set up a cloud for exploring OpenStack, it's hard to debug when anything goes wrong. Packstack is a better alternative.

Having said that, check the Neutron server log, usually /opt/stack/logs/q-srv.log (I am not sure what the precise name is, but it starts with q-). Also, I think you haven't switched on DEBUG logging. Do this so that the stack.sh log file contains more information.

You can also read the shell scripts mentioned in the error output, to find out how DevStack determines that Neutron is not running.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-03-31 18:27:44 -0500

Seen: 713 times

Last updated: Apr 01 '17