Getting error Pre installing Puppet and discovering hosts' details[ ERROR ]

asked 2017-03-31 07:23:36 -0600

goldynavik gravatar image

Deploying multinode :

getting error

"Pre installing Puppet and discovering hosts' details[ ERROR ]"

[root@controller ~]# packstack --answer-file=/root/answer.txt Welcome to the Packstack setup utility

The installation log file is available at: /var/tmp/packstack/20170331-083927-czJ9mN/openstack-setup.log

Installing: Clean Up [ DONE ] Discovering ip protocol version [ DONE ] Setting up ssh keys [ DONE ] Preparing servers [ DONE ] Pre installing Puppet and discovering hosts' details[ ERROR ]

ERROR : Failed to run remote script, stdout: Loaded plugins: fastestmirror, langpacks Loading mirror speeds from cached hostfile * base: http://mirror.web-ster.com * extras: http://mirror.cs.uwp.edu * updates: http://ftpmirror.your.org Package 2:nmap-ncat-6.40-7.el7.x86_64 already installed and latest version Resolving Dependencies --> Running transaction check ---> Package hiera.noarch 1:1.3.4-5.el7 will be installed --> Processing Dependency: ruby(release) for package: 1:hiera-1.3.4-5.el7.noarch ---> Package openssh-clients.x86_64 0:6.6.1p1-22.el7 will be updated ---> Package openssh-clients.x86_64 0:6.6.1p1-33.el7_3 will be an update ---> Package puppet.noarch 0:4.6.2-2.el7 will be installed --> Processing Dependency: facter >= 1.6.6 for package: puppet-4.6.2-2.el7.noarch --> Processing Dependency: rubygem(rgen) for package: puppet-4.6.2-2.el7.noarch --> Processing Dependency: ruby(shadow) for package: puppet-4.6.2-2.el7.noarch --> Processing Dependency: ruby(selinux) for package: puppet-4.6.2-2.el7.noarch --> Processing Dependency: ruby(augeas) for package: puppet-4.6.2-2.el7.noarch --> Processing Dependency: ruby for package: puppet-4.6.2-2.el7.noarch --> Processing Dependency: /usr/bin/ruby for package: puppet-4.6.2-2.el7.noarch ---> Package rubygem-json.x86_64 0:1.7.7-29.el7 will be installed --> Processing Dependency: ruby(rubygems) >= 2.0.14.1 for package: rubygem-json-1.7.7-29.el7.x86_64 ---> Package tar.x86_64 2:1.26-29.el7 will be updated ---> Package tar.x86_64 2:1.26-31.el7 will be an update --> Running transaction check ---> Package facter.x86_64 1:2.4.4-4.el7 will be installed ---> Package libselinux-ruby.x86_64 0:2.5-6.el7 will be installed ---> Package ruby.x86_64 0:2.0.0.648-29.el7 will be installed --> Processing Dependency: rubygem(bigdecimal) >= 1.2.0 for package: ruby-2.0.0.648-29.el7.x86_64 ---> Package ruby-augeas.x86_64 0:0.5.0-1.el7 will be installed ---> Package ruby-libs.x86_64 0:2.0.0.648-29.el7 will be installed ---> Package ruby-shadow.x86_64 0:1.4.1-23.el7 will be installed ---> Package rubygem-rgen.noarch 0:0.6.6-2.el7 will be installed ---> Package rubygems.noarch 0:2.0.14.1-29.el7 will be installed --> Processing Dependency: rubygem(rdoc) >= 4.0.0 for package: rubygems-2.0.14.1-29.el7.noarch --> Processing Dependency: rubygem(psych) >= 2.0.0 for package: rubygems-2.0.14.1-29.el7.noarch --> Processing Dependency: rubygem(io-console) >= 0.4.2 for package: rubygems-2.0.14.1-29.el7.noarch --> Running transaction check ---> Package rubygem-bigdecimal.x86_64 0:1.2.0-29.el7 will be installed ---> Package rubygem-io-console.x86_64 0:0.4.2-29.el7 will be installed ---> Package rubygem-psych.x86_64 0:2.0.0-29.el7 will be installed --> Processing Dependency: libyaml-0.so.2()(64bit) for package: rubygem-psych-2.0.0-29.el7.x86_64 ---> Package rubygem-rdoc.noarch ... (more)

edit retag flag offensive close merge delete