how to force nova to use openvswitch?

asked 2017-03-30 09:14:54 -0500

minimike gravatar image

Hi there

I've got an issue by creating HVM guests. My environment Ubuntu 17.04 with XEN 4.8 (xenproject) nova 7.1.0, libvirtd 2.5.0, openvswitch 2.6.1. So far OpenStack Ocata.. The issue is that the virtual interface by creating an HVM Guest couldn't be plugged into an ovs-bridge. At first I thougt nova and or libvrtd are using wrong scripts like /etc/xen/scripts/vif-bridge. But then I have found that by creating an instance then will be created an linuxbridge they would be pluggend into openvswitch after. Another issue that I have seen by using linuxbridges instead of openvswitch is that the names of the virtual interfaces are to long. So brctl couldn't work with it. The issue with the to long names is only present by creating HVM guests. That descibes me what ist going wrong here.. But not why

After reading many times consulting the documentation, I've tried to force nova to use openvswitch. But still brctl is used :( http://paste.openstack.org/show/604857/

anyway is there a way by using xen over libvirt to force nova to use openvswitch? I would like to use openvswitch because that is stay of the art. And with linuxbridge I've got the issue that interfaces with to long names would been generated.

The issue is almost best to see in my syslog.

here an successful deployment of an PVM guest http://paste.openstack.org/show/604853/

here an failed deployment of an HVM Guest http://paste.openstack.org/show/604858/

edit retag flag offensive close merge delete

Comments

for testing I've switched to KVM. HVM guests runs, but the same behavior with bridges. Bridges are created by creating the instance and attached to openvswitch. That sounds for me cruel

minimike gravatar imageminimike ( 2017-03-30 16:12:26 -0500 )edit