Ocata Instance can not startup with cirros image

asked 2017-03-29 22:53:57 -0600

AlexJia gravatar image

updated 2017-03-30 11:46:43 -0600

I installed the openstack components based on Ocata version. After configuration, the instance can not boot up with image cirros. From the console, I can get below lines:

**SeaBIOS (version 1.9.1-5.el7_3.2)
Machine UUID 669dbc1f-55ad-47f6-bb6b-83954ce0cc87
iPXE (http://ipxe.org) 00:03.0 C980 PCI2.10 PnP PMM  (Stopped at here)****

(openstack) compute service list
+----+------------------+-----------------------+----------+---------+-------+----------------------------+
| ID | Binary           | Host                  | Zone     | Status  | State | Updated At                 |
+----+------------------+-----------------------+----------+---------+-------+----------------------------+
|  1 | nova-scheduler   | controller            | internal | enabled | up    | 2017-03-30T03:51:26.000000 |
|  2 | nova-consoleauth | controller            | internal | enabled | up    | 2017-03-30T03:51:35.000000 |
|  3 | nova-conductor   | controller            | internal | enabled | up    | 2017-03-30T03:51:35.000000 |
|  6 | nova-compute     | localhost.localdomain | nova     | enabled | up    | 2017-03-30T03:51:26.000000 |
|  7 | nova-compute     | alex.study            | nova     | enabled | up    | 2017-03-30T03:51:29.000000 |
+----+------------------+-----------------------+----------+---------+-------+----------------------------+
(openstack) network list
+--------------------------------------+----------+--------------------------------------+
| ID                                   | Name     | Subnets                              |
+--------------------------------------+----------+--------------------------------------+
| 695ee599-e446-4bc8-ba81-ff38ed55877a | provider | a168be5f-9e48-4f3b-89e4-ef332780db49 |
+--------------------------------------+----------+--------------------------------------+
(openstack)  server list
+--------------------------------------+-------+--------+----------------------+-------------+
| ID                                   | Name  | Status | Networks             | Image Name  |
+--------------------------------------+-------+--------+----------------------+-------------+
| 669dbc1f-55ad-47f6-bb6b-83954ce0cc87 | TEST2 | ACTIVE | provider=10.7.117.78 | cirros_test |
+--------------------------------------+-------+--------+----------------------+-------------+
(openstack) service list 
+----------------------------------+-----------+-----------+
| ID                               | Name      | Type      |
+----------------------------------+-----------+-----------+
| 1b16dbf2522d483da5bcffba98ce66d3 | keystone  | identity  |
| 4d2abf4fecfe4fb8bc1f77468b6f5577 | placement | placement |
| 65451d1f28214be38501b012acc63b13 | glance    | image     |
| 81266ae71d7c485bae32f49e80223a31 | placement | placement |
| cdf2bf28a7b444d29cca22c3473cebba | nova      | compute   |
| e7e511a171bc4dc2a7177ee213c2a1ff | neutron   | network   |
+----------------------------------+-----------+-----------+
(openstack)

Could you please help me on this, what I need to check and fix this issue?

edit retag flag offensive close merge delete

Comments

your instance tries PXE booting because it doesn't see a bootable disk.You need to check the image or volume you used to launch the instance.

Bernd Bausch gravatar imageBernd Bausch ( 2017-03-30 11:47:56 -0600 )edit