Ask Your Question

Neutron doesn't know what lbaas is

asked 2017-03-29 12:48:17 -0500

milo22 gravatar image

I've been trying to get the v2 load balancer setup in Openstack using the official documentation(

Following the steps I get stuck at step 4:

Step 1: Edit this file /etc/neutron/neutron.conf

Step 2: Edit this file /etc/neutron/neutron_lbaas.conf ( doesn't exist for me but I created it anyway).
Step 3: Edit this file /etc/neutron/lbaas_agent.ini ( doesn't exist for me but I created it anyway).
Step 4: Run this command (neutron-db-manage --subproject neutron-lbaas upgrade head). After running it Neutron says it doesn't know what neutron-lbaas is.


[root@controller ~]# neutron-db-manage --subproject neutron-lbaas upgrade head argument --subproject: Invalid String(choices=['neutron']) value: neutron-lbaas

I get this same output from an all-in-one RDO installation and a manual 4 node installation of Ocata.

What am I doing wrong?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2017-03-30 04:38:09 -0500

Rajesh Ramachandran gravatar image

LBAAS package should be missing.

Install the package "openstack-neutron-lbaas". It should create the configuration files and you can edit those.

edit flag offensive delete link more


Thank you! I now have another issue. I get this output when I trying to run this command and admin-openrc : neutron lbaas-loadbalancer-create --name test-lb private Driver error: The request you have made requires authentication. (HTTP 401) (Request-ID: req-e166c45c-4605-4ae7-b336-160e2f936ef1

milo22 gravatar imagemilo22 ( 2017-03-30 09:55:19 -0500 )edit

@milo22: I have the same issue, maybe you resolved that already?

crazik gravatar imagecrazik ( 2017-04-28 03:27:21 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2017-03-29 12:48:17 -0500

Seen: 645 times

Last updated: Mar 30 '17