Ask Your Question

How to enable audio on my instance?

asked 2014-01-14 15:53:43 -0500

corabian gravatar image

updated 2014-01-14 15:54:37 -0500

Hi Guys, I'm running a three node OpenStack Havana installation deployed with this guide:

Everything looks fine with the installation and I'm doing some tests with SPICE, but seems that my instances don't have any audio device available. How can I add it?

I found some posts saying that one option would be changing libvirt.xml.template and add the following entry:

 <sound model='ich6'>
  <codec type='micro'/>

But seems that after Folsom this libvirt-template-file-approach has been changed into an object model ( ). Here is the information from inside the instance:

# uname -a
Linux ubuntu-spice 3.2.0-57-virtual #87-Ubuntu SMP Tue Nov 12 21:53:49 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
# cat /etc/issue
Ubuntu 12.04.3 LTS \n \l
# lspci -v | grep Audio
# ls /sbin/alsa-utils*
ls: cannot access /sbin/alsa-utils*: No such file or directory
# aplay -l
aplay: device_list:252: no soundcards found...
# ls /proc/asound*
ls: cannot access /proc/asound*: No such file or directory

Thanks in advance and let me know if any extra information is required.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2014-01-14 17:16:27 -0500

SamYaple gravatar image

We made the changes listed here to get that to work. I had to use ac97 to have audio work with Windows. YMMV.

Link -

edit flag offensive delete link more


This thread is rather old, but I'm still struggling with sound on a Windows VM. If I add <sound model='ich6'> <alias name='sound0'/> <address [...]/> </sound> to the xml of a running instance this works only if openstack is not involved. Is there still only the hacking way?

eblock gravatar imageeblock ( 2019-02-22 08:18:01 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2014-01-14 15:53:43 -0500

Seen: 1,510 times

Last updated: Jan 14 '14