Tacker: heat.engine.resource ConnectFailure: Unable to establish connection to http://controller:8042/v2/alarms

asked 2017-03-28 07:11:25 -0500

AB239 gravatar image

updated 2017-03-28 07:14:17 -0500

Hello,

I am getting "heat.engine.resource ConnectFailure: Unable to establish connection to http://controller:8042/v2/alarms" error while trying to launch a VNF using tacker. Here is my template:

VDU1:
  type: tosca.nodes.nfv.VDU.Tacker
  properties:
    image: {get_input: image}
    flavor: {get_input: flavor} 
    availability_zone: {get_input: zone}
    name: xyz
    mgmt_driver: noop

CP_repo_dns_publicnet:
  type: tosca.nodes.nfv.CP.Tacker
  properties:
    management: true
    order: 0
    anti_spoofing_protection: false
  requirements:
    - virtualLink:
        node: VL_publicnet
    - virtualBinding:
        node: VDU1

CP_repo_dns_priv1:
  type: tosca.nodes.nfv.CP.Tacker
  properties:
    management: true
    order: 0
    anti_spoofing_protection: false
  requirements:
    - virtualLink:
        node: VL_priv1
    - virtualBinding:
        node: VDU1

CP_repo_dns_priv2:
  type: tosca.nodes.nfv.CP.Tacker
  properties:
    order: 1
    anti_spoofing_protection: false
  requirements:
    - virtualLink:
        node: VL_priv2
    - virtualBinding:
        node: VDU1

  policies:
    - SP1:
        type: tosca.policy.tacker.Scaling
        properties:
          increment: 1
          cooldown: 60
          min_instances: 1
          max_instances: 3
          default_instances: 2
          targets: [VDU1]

- vdu1_cpu_usage_monitoring_policy_2:
    type: tosca.policies.tacker.Alarming
    triggers:
        resize_compute:
            event_type:
                type: tosca.events.resource.utilization
                implementation: ceilometer
            metrics: cpu_util
            condition:
                threshold: 10
                constraint: utilization less_than 10%
                period: 200
                evaluations: 1
                method: avg
                comparison_operator: lt
            action:
              resize_compute:
                action_name: SP1

Detailed error:

http://paste.openstack.org/show/604466/

Please let me know how to troubleshoot this? I cant see any reference of port 8042 in any of my conf files.

edit retag flag offensive close merge delete

Comments

Ceilometer alarm is deprecated and now uses aodh service. Configure it and all will be fine

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2017-03-28 11:13:45 -0500 )edit

Thanks for the reply. I am indeed using Aodh in my machine. Thats why I dont understand this error.

AB239 gravatar imageAB239 ( 2017-03-30 01:25:45 -0500 )edit

Is aodh working? check aodh alarm list. If is not working please share aodh config, check if the port is bind in the node, try to telnet to it. If is under a loadbalancer, check if the balancer know where to send the request. btw, port 8042 is oadh api, can also check if the endpoint exists

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2017-03-30 04:41:21 -0500 )edit

Yes aodh is working. My aodh alarm list shows correct alarm. Now I am getting this error in tacker.log file ERROR oslo_middleware.catch_errors Unauthorized: The request you have made requires authentication. (HTTP 401) (Request-ID: req-3173982b-defc-4a40-a854-5c04cd1e59a4)

AB239 gravatar imageAB239 ( 2017-03-31 01:43:04 -0500 )edit

@Eduardo Gonzalez: Can u please look into this as well?

AB239 gravatar imageAB239 ( 2017-04-03 00:10:05 -0500 )edit