Ask Your Question
1

openstack endpoint list fails with message "Failed to contact the endpoint at http://controller:35357/v3/ for discovery"

asked 2017-03-24 08:28:05 -0500

Rajesh Ramachandran gravatar image

updated 2017-03-27 15:51:29 -0500

rbowen gravatar image

Hi, I am trying to deploy a single node openstack on a Centos VM following the guide :

https://docs.openstack.org/ocata/inst...

I have installed Identity Service and was attempting to create a "service" project which is when I get this error :

# openstack project create --domain default   --description "Service Project" service
Failed to contact the endpoint at http://controller:35357/v3/ for discovery. Fallback to using that endpoint as the base url.
Failed to contact the endpoint at http://controller:35357/v3/ for discovery. Fallback to using that endpoint as the base url.
Failed to contact the endpoint at http://controller:35357/v3/ for discovery. Fallback to using that endpoint as the base url.
Failed to contact the endpoint at http://controller:35357/v3/ for discovery. Fallback to using that endpoint as the base url.
Unable to establish connection to http://controller:35357/v3/domains?: HTTPConnectionPool(host='controller', port=35357): Max retries exceeded with url: /v3/domains (Caused by NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0x3e3db90>: Failed to establish a new connection: [Errno -2] Name or service not known',))
[root@rajesh ~]#

I understand I would have made some mistake in configuation of http or keystone.conf, but couldn't figure out. Any pointers please ?

Here is my output from keystone.conf and httpd.conf:

[root@rajesh ~]# cat /etc/keystone/keystone.conf | grep -i "connection ="
connection = mysql+pymysql://keystone:openstack@{Controller IP address entered}/keystone

[root@rajesh ~]# cat /etc/httpd/conf/httpd.conf | grep -i ServerName
ServerName "rajesh.manual"
[root@rajesh ~]#


[root@rajesh ~]# hostname
rajesh.manual
[root@rajesh ~]#
edit retag flag offensive close merge delete

Comments

I would check the httpd configuration for Keystone, in particular what LISTEN addresses are specified. Or perhaps the Keystone processes are not running, in which case the keystone log file might tell you why.

Bernd Bausch gravatar imageBernd Bausch ( 2017-03-27 19:10:54 -0500 )edit

Thanks Bernd for your suggestions !!

Rajesh Ramachandran gravatar imageRajesh Ramachandran ( 2017-03-30 01:49:46 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-03-28 02:25:06 -0500

Rajesh Ramachandran gravatar image

Ok, it seems that while doing the "Bootstap of Identity service" I used "controller" as the name instead of my controller IP. And there was no reference for my controller IP to point to the name "controller".

Command which I used :

 # keystone-manage bootstrap --bootstrap-password ADMIN_PASS \
  --bootstrap-admin-url http://controller:35357/v3/ \
  --bootstrap-internal-url http://controller:5000/v3/ \
  --bootstrap-public-url http://controller:5000/v3/ \
  --bootstrap-region-id RegionOne

My Keystone DB was pointing to http://controller:%3Cport%3E (http://controller:<port></port>), whereas my AUTH_URL which I sourced was http:{controller IP}

As a fix, I added 127.0.0.1 controller to /etc/hosts file.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-03-24 08:25:02 -0500

Seen: 2,632 times

Last updated: Mar 28 '17