Ask Your Question
0

Howto use Horizon with nova-network (Havana / Ubuntu 12.04)

asked 2014-01-14 10:52:44 -0500

updated 2014-01-22 03:43:00 -0500

Hi,

I'm trying to install OpenStack according to http://docs.openstack.org/havana/install-guide/install/apt/content/ I'm trying to install on a single node and a single network interface. This is my third attempt ;) so I'm a little frustrated. After failing with Grizzly/Neutron and Havana/Neutron, this time I tried installing with nova-network (FlatDHCPManager).

Currently I'm stuck with starting Horizon, because it's missing Neutron. Apache error.log:

[Tue Jan 14 16:40:47 2014] [error] Internal Server Error: /horizon/admin/
[Tue Jan 14 16:40:47 2014] [error] Traceback (most recent call last):
[Tue Jan 14 16:40:47 2014] [error]   File "/usr/lib/python2.7/dist-packages/django/core/handlers/base.py", line 115, in get_response
[Tue Jan 14 16:40:47 2014] [error]     response = callback(request, *callback_args, **callback_kwargs)
[Tue Jan 14 16:40:47 2014] [error]   File "/usr/lib/python2.7/dist-packages/horizon/decorators.py", line 38, in dec
[Tue Jan 14 16:40:47 2014] [error]     return view_func(request, *args, **kwargs)
[Tue Jan 14 16:40:47 2014] [error]   File "/usr/lib/python2.7/dist-packages/horizon/decorators.py", line 86, in dec
[Tue Jan 14 16:40:47 2014] [error]     return view_func(request, *args, **kwargs)
[Tue Jan 14 16:40:47 2014] [error]   File "/usr/lib/python2.7/dist-packages/horizon/decorators.py", line 54, in dec
[Tue Jan 14 16:40:47 2014] [error]     return view_func(request, *args, **kwargs)
[Tue Jan 14 16:40:47 2014] [error]   File "/usr/lib/python2.7/dist-packages/horizon/decorators.py", line 38, in dec
[Tue Jan 14 16:40:47 2014] [error]     return view_func(request, *args, **kwargs)
[Tue Jan 14 16:40:47 2014] [error]   File "/usr/lib/python2.7/dist-packages/horizon/decorators.py", line 86, in dec
[Tue Jan 14 16:40:47 2014] [error]     return view_func(request, *args, **kwargs)
[Tue Jan 14 16:40:47 2014] [error]   File "/usr/lib/python2.7/dist-packages/django/views/generic/base.py", line 68, in view
[Tue Jan 14 16:40:47 2014] [error]     return self.dispatch(request, *args, **kwargs)
[Tue Jan 14 16:40:47 2014] [error]   File "/usr/lib/python2.7/dist-packages/django/views/generic/base.py", line 86, in dispatch
[Tue Jan 14 16:40:47 2014] [error]     return handler(request, *args, **kwargs)
[Tue Jan 14 16:40:47 2014] [error]   File "/usr/lib/python2.7/dist-packages/horizon/tables/views.py", line 155, in get
[Tue Jan 14 16:40:47 2014] [error]     handled = self.construct_tables()
[Tue Jan 14 16:40:47 2014] [error]   File "/usr/lib/python2.7/dist-packages/horizon/tables/views.py", line 146, in construct_tables
[Tue Jan 14 16:40:47 2014] [error]     handled = self.handle_table(table)
[Tue Jan 14 16:40:47 2014] [error]   File "/usr/lib/python2.7/dist-packages/horizon/tables/views.py", line 118, in handle_table
[Tue Jan 14 16:40:47 2014] [error]     data = self._get_data_dict()
[Tue Jan 14 16:40:47 2014] [error]   File "/usr/lib/python2.7/dist-packages/horizon/tables/views.py", line 182, in ...
(more)
edit retag flag offensive close merge delete

5 answers

Sort by ยป oldest newest most voted
1

answered 2014-01-21 15:35:23 -0500

Found the solution.

In local_settings.py you have to comment in OPENSTACK_NEUTRON_NETWORK and set enable_lb to False. That solved the issue for me

edit flag offensive delete link more

Comments

Would you mind filing a bug about this at https://bugs.launchpad.net/horizon ? This shouldn't be happening. Thank you!

jpichon gravatar imagejpichon ( 2014-01-22 07:03:12 -0500 )edit

Thank you!

jpichon gravatar imagejpichon ( 2014-01-27 10:42:03 -0500 )edit
1

answered 2014-01-23 06:44:09 -0500

daniel-kuffner gravatar image

As already mentioned horizon uses keystone to figure out if neutron or nova network is in use.

  1. Remove neutron from the service catalog: keystone service-delete neutron
  2. Make sure all neutron service are stopped.
  3. Make sure nova network service are started.
  4. Restart apache: service httpd restart
  5. Goto dashboard and login in (you might have to throw away the cookie).
edit flag offensive delete link more

Comments

1. Neutron is not and was never in the keystone service-list 2. Neutron packages were never installed on that system 3. They are and were 4. ;) Did that multiple times 5. Even used different browsers

Sascha Vogt gravatar imageSascha Vogt ( 2014-01-24 01:45:53 -0500 )edit
0

answered 2014-01-20 06:03:21 -0500

jpichon gravatar image

Horizon uses the Keystone catalogue ($ keystone catalog) to determine what services are installed. If you don't have Neutron installed, make sure the service isn't defined (and no endpoints are set up) for Neutron in your Keystone catalogue.

If it is - you'll need to remove the service and endpoints, then log out and back in to Horizon again (available services are picked up once at login time).

Hope this helps!

edit flag offensive delete link more
0

answered 2014-01-20 03:46:28 -0500

shalmali gravatar image

Go to the mysql and run flush hosts command.

run following commands: 1. # mysql -u root -p 2. mysql> use keystone; Database changed 3.FLUSH HOSTS;

and Done. These steps resolved my issue !! hope this works for you as well !!

edit flag offensive delete link more
-2

answered 2014-01-14 10:59:34 -0500

dheeru gravatar image

Horizon is not at all required. My suggestion is don't go to Horizon unless you are sure that instances are created and etc. I have installed Ubuntu single node with one NIC. It works perfectly. I'm writing technical document on the same and will be shared shortly. I have done step-by-step instruction. If you want I can send you the sample configuration files for Single Node Ubuntu Havana.

edit flag offensive delete link more

Comments

That would be great! Nevertheless, is it possible to use Horizon without Neutron installed?

Sascha Vogt gravatar imageSascha Vogt ( 2014-01-14 11:04:56 -0500 )edit

Neutron is must for creating the instance. Otherwise how will you get the ip address for instances ?

dheeru gravatar imagedheeru ( 2014-01-14 11:09:44 -0500 )edit

Ok, added an instance via cmdline, and it boots and I can log in via SSH, so that all works

Sascha Vogt gravatar imageSascha Vogt ( 2014-01-14 11:10:35 -0500 )edit

As I've written in the question: nova-network and the FlatDHCPManager

Sascha Vogt gravatar imageSascha Vogt ( 2014-01-14 11:11:51 -0500 )edit

Then you should not face any problem. It should work fine.

dheeru gravatar imagedheeru ( 2014-01-14 12:00:57 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-01-14 10:52:44 -0500

Seen: 1,051 times

Last updated: Jan 23 '14