Ask Your Question

openstack using packstack(RDO) on rhel 7.1 gets stuck

asked 2017-03-24 03:15:38 -0500

gayatri gravatar image

updated 2017-03-27 15:53:06 -0500

rbowen gravatar image

I am trying to install openstack ocata on rhel 7.1 using packstack. I am using the following link for installation: The installation gets stuck at the step showing the message "Testing if puppet apply is finished". Can anyone help me to solve this issue?

edit retag flag offensive close merge delete


If you can provide log entries, that will be very helpful in getting to the bottom of this.

rbowen gravatar imagerbowen ( 2017-03-27 15:53:43 -0500 )edit

there is no packstack folder in var/log/ directory so there is only openstack-setup.log which i found out in /var/tmp/packstack/ folder.

gayatri gravatar imagegayatri ( 2017-03-30 08:29:25 -0500 )edit

For how long have you waited? That "Testing if puppet apply is finished" process takes a long time depending on your hardware.

Jay Montoya gravatar imageJay Montoya ( 2017-03-30 17:42:47 -0500 )edit

I have waited for more than 4 hours

gayatri gravatar imagegayatri ( 2017-04-03 00:44:35 -0500 )edit

6 answers

Sort by ยป oldest newest most voted

answered 2018-07-02 02:21:23 -0500

adil-openstack gravatar image

i have the same problem.. the problem solved by: 1. check the /etc/hosts file 2. make sure ur IP address is in the file. 3. also make sure ur packstack file have CONFIG_KEYSTONE_ADMIN_PW= <ur password="">

this solve my problem. after all, just check all ur configuration.

edit flag offensive delete link more

answered 2017-04-01 03:23:08 -0500

jklu gravatar image

Tried the same thing last night: after 2,5 hours puppet was still busy: System spec: - i7 4700MQ - 1 TB 7200RPM disk - 8 GB RAM - RHEL 7.3 clean install of "server + gui" - Wifi network (its a laptop)

ran packstack --allinone

According to "top" system started swapping after 50 minutes or so, having absorbed all RAM. Top memory users being puppet (6%) and *-api processes at around 2% each. 17 nova-api processes running at the same time. Total number of processes present on the box above 450.

/var/lib shows dirs being added (nova, cinder, redis, gnocci etc) until swapping starts

Last entries in the openstack-setup.log are:
cd /usr/share/openstack-puppet/modules
tar --dereference -cpzf - aodh apache ceilometer certmonger cinder concat firewall glance gnocchi heat horizon inifile ironic keystone magnum manila memcached mongodb mysql neutron nova nssdb openstack openstacklib oslo packstack panko rabbitmq redis remote rsync sahara ssh stdlib swift sysctl tempest trove vcsrepo vswitch xinetd | ssh -o StrictHostKeyChecking=no -o UserKnownHostsFile=/dev/null root@ tar -C /var/tmp/packstack/dc47e9fea0d74bd99031dad3e64afce4/modules -xpzf -

edit flag offensive delete link more


Ok, think I found the issue..
looking .at /etc/nova/nova.conf
#Number of workers for OpenStack API service. The default will be the number
# of CPUs available.
As the CPU has 8 hyperthreads, RHEL is reporting it as 8 cores. This explains the explosion in processes

jklu gravatar imagejklu ( 2017-04-01 13:33:44 -0500 )edit

ideally the --allinone should put in sensible limits as all processes will be running a single node.

jklu gravatar imagejklu ( 2017-04-01 13:35:12 -0500 )edit

@jklu what should be the value set for number of workers for openstack API service?

gayatri gravatar imagegayatri ( 2017-04-04 04:18:02 -0500 )edit

Got my All In One setup working by specifying: CONFIG_SERVICE_WORKERS=1 in the packstack answer file

On my setup it takes packstack about 35 mins to complete

jklu gravatar imagejklu ( 2017-04-24 09:29:01 -0500 )edit

the problems is with the IPtables in the controller node, you need add some rule with the IP of yhe news computer nodes in /etc/sysconfig/iptables

Jorge Armando gravatar imageJorge Armando ( 2019-12-07 23:27:46 -0500 )edit

answered 2019-10-18 15:19:21 -0500

I think the message should be changed to indicate this is a long-running process. Ideally a percent complete would be great. On my rig, it took 15 minutes but that was after I killed it multiple times thinking it was frozen.

edit flag offensive delete link more

answered 2017-03-28 05:52:10 -0500

ShubhamMeshram gravatar image

You must wait, The Testing if puppet apply is finished". takes more than an hour but it does execute. You gotta wait. and pls be sure you're doing it on a machine with powerful configuration other the system lags

edit flag offensive delete link more

answered 2017-03-28 05:27:43 -0500

Rajesh Ramachandran gravatar image

There is a possibility that the server doesn't have enough memory. Check the RAM size during the installation. Recommended size is 5 to 6GB. Also, check whether the NetworkManager and firewalld is disabled. You can check logs under /var/tmp/packstack/ which will give pointers if the issue is otherwise.

edit flag offensive delete link more


ram allocated is 10 gb and firewall and network manager are disabled. which directory should I look into for issues?

gayatri gravatar imagegayatri ( 2017-03-30 08:30:04 -0500 )edit

answered 2017-04-21 05:14:02 -0500

gayatri gravatar image

updated 2017-04-21 05:26:39 -0500

Some of the repos were missing and after enabling those repos the packstack installation completes. To find which repos are missing check the log files in manifests folder in /var/tmp/packstack/instal_folder_timestamp_directory/manifests/ directory

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools


Asked: 2017-03-24 03:15:38 -0500

Seen: 9,532 times

Last updated: Oct 18 '19