Ask Your Question
0

Unable to launch Openstack ocata dashboard

asked 2017-03-24 01:02:03 -0500

Mashkoor gravatar image

updated 2017-03-27 15:52:47 -0500

rbowen gravatar image

Dear all,

I have installed the openstack Ocata on 3 nodes with RDO repository. I got the successful installation message. However launching dashboard says " Could Not Connect Description: Could not connect to the requested server host. "

Any Idea?

How ever from my LAN I am able to access the "apache test page" with the same IP address.

edit retag flag offensive close merge delete

Comments

Does "launch the dashboard" mean running the horizon server under Apache or directing your browser to the controller? Where do you see the error message, browser, command line, log file, elsewhere?

Also what do you mean by "successful installation message"? How did you install OpenStack?

Bernd Bausch gravatar imageBernd Bausch ( 2017-03-24 01:04:18 -0500 )edit

The horizon is configured under apache as virtual host. The message comes on the browser. The installation process with done by generating answer file and changing the nodes information in answer file. follow the instructions from RDO site. packstack --answer-file=answer.cfg

Mashkoor gravatar imageMashkoor ( 2017-03-24 01:30:46 -0500 )edit

So what happens precisely? You enter the URL, then get the error? Or you get the login form, enter credentials, then get the error? Or get the error at a different stage?

In any case, you need to check the log files, probably /var/log/httpd(???) and /var/log/horizon.

Bernd Bausch gravatar imageBernd Bausch ( 2017-03-24 01:35:00 -0500 )edit
1

Getting error message after accessing the dashboard with ip or hostname on the browser no login page appears on the screen. The screen show the above mentioned message on the page instead of login screen.

Mashkoor gravatar imageMashkoor ( 2017-03-24 02:39:59 -0500 )edit

[:error] [pid 14951] WARNING:root:"dashboards" and "default_dashboard" in (local_)settings is DEPRECATED now and may be unsupported in some future release. The preferred way to specify the order of dashboar ds and the default dashboard is the pluggable dashboard mechanism (in /usr/share /openstack-d

Mashkoor gravatar imageMashkoor ( 2017-03-24 02:43:38 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-03-28 00:02:25 -0500

Mashkoor gravatar image

updated 2017-03-28 00:04:46 -0500

Bernd Bausch Thanks for helping.

changing the ownership to apache on "/usr/share/openstack-dashboard/openstack_dashboard/local/"* directory resolved the problem.

Thanks again.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2017-03-24 01:02:03 -0500

Seen: 1,243 times

Last updated: Mar 28 '17