Ask Your Question
0

How to make SfcOVSAgentDriver work in networking-sfc,version Newton.

asked 2017-03-22 09:18:06 -0500

joezts gravatar image

I installed OpenStack Newton manually, following the official installation guide.

Everything works well without networking-sfc. I can create port-pair, port pair group, flow classifier and port chain, but there is no sfc flows in br-int or br-tun.

At first, I added some items in neutron.conf.

#vim /etc/neutron/neutron.conf
[DEFAULT]
service_plugins = router,flow_classifier,sfc

[sfc]
drivers = ovs
agent_drivers = ovs

[flowclassifier]
drivers = ovs

And then I found the problem is that SfcOVSAgentDriver didn't start to work.

https://bugs.launchpad.net/networking-sfc/+bug/1586024 (https://bugs.launchpad.net/networking...)

link above points out that we should adding sfc to agent->extensions configuration parameter in ml2_conf.ini.So I add some items in configuration file, showing below

# vim /etc/neutron/plugins/ml2/ml2_conf.ini
[agent]
extensions = sfc

# In both Network Node and Compute Node
# vim /etc/neutron/plugins/ml2/openvswitch_agent.ini
[agent]
extensions = sfc

But the SfcOVSAgentDriver still doesn't work. This question has been puzzling me for a long time. It almost drives me crazy. Can anybody tell me how to solve it ? Did I wrongly config the configuration file?

Thanks very much!

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2017-04-06 02:16:48 -0500

joezts gravatar image

I have solved this problem.

On Compute node, we need to install networking-sfc as well. After that, there will be sfc flows in br-int when we create port-chain.

Hope this helps.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-03-22 09:18:06 -0500

Seen: 205 times

Last updated: Apr 06 '17