devstack ContextualVersionConflict

asked 2017-03-21 13:40:52 -0600

javibr gravatar image

Hi im having the following error once I laun stack.sh in the last stable version

sudo -H http_proxy= https_proxy= no_proxy= PIP_FIND_LINKS= SETUPTOOLS_SYS_PATH_TECHNIQUE=rewrite /usr/local/bin/pip2.7 install -c /opt/stack/requirements/upper-constraints.txt -e /opt/stack/glance
2017-03-21 17:32:36.166 | Ignoring dnspython3: markers 'python_version == "3.4"' don't match your environment
2017-03-21 17:32:36.404 | Obtaining file:///opt/stack/glance
2017-03-21 17:32:38.075 | Exception:
2017-03-21 17:32:38.075 | Traceback (most recent call last):
2017-03-21 17:32:38.075 |   File "/usr/local/lib/python2.7/dist-packages/pip/basecommand.py", line 215, in main
2017-03-21 17:32:38.075 |     status = self.run(options, args)
2017-03-21 17:32:38.075 |   File "/usr/local/lib/python2.7/dist-packages/pip/commands/install.py", line 335, in run
2017-03-21 17:32:38.075 |     wb.build(autobuilding=True)
2017-03-21 17:32:38.075 |   File "/usr/local/lib/python2.7/dist-packages/pip/wheel.py", line 749, in build
2017-03-21 17:32:38.075 |     self.requirement_set.prepare_files(self.finder)
2017-03-21 17:32:38.075 |   File "/usr/local/lib/python2.7/dist-packages/pip/req/req_set.py", line 380, in prepare_files
2017-03-21 17:32:38.075 |     ignore_dependencies=self.ignore_dependencies))
2017-03-21 17:32:38.075 |   File "/usr/local/lib/python2.7/dist-packages/pip/req/req_set.py", line 521, in _prepare_file
2017-03-21 17:32:38.075 |     req_to_install.check_if_exists()
2017-03-21 17:32:38.075 |   File "/usr/local/lib/python2.7/dist-packages/pip/req/req_install.py", line 1036, in check_if_exists
2017-03-21 17:32:38.075 |     self.req.name
2017-03-21 17:32:38.075 |   File "/usr/local/lib/python2.7/dist-packages/pip/_vendor/pkg_resources/__init__.py", line 558, in get_distribution
2017-03-21 17:32:38.075 |     dist = get_provider(dist)
2017-03-21 17:32:38.075 |   File "/usr/local/lib/python2.7/dist-packages/pip/_vendor/pkg_resources/__init__.py", line 432, in get_provider
2017-03-21 17:32:38.075 |     return working_set.find(moduleOrReq) or require(str(moduleOrReq))[0]
2017-03-21 17:32:38.075 |   File "/usr/local/lib/python2.7/dist-packages/pip/_vendor/pkg_resources/__init__.py", line 968, in require
2017-03-21 17:32:38.075 |     needed = self.resolve(parse_requirements(requirements))
2017-03-21 17:32:38.075 |   File "/usr/local/lib/python2.7/dist-packages/pip/_vendor/pkg_resources/__init__.py", line 859, in resolve
2017-03-21 17:32:38.075 |     raise VersionConflict(dist, req).with_context(dependent_req)
2017-03-21 17:32:38.075 | ContextualVersionConflict: (keystoneauth1 2.4.3 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('keystoneauth1>=2.16.0'), set(['castellan']))
2017-03-21 17:32:38.198 | +inc/python:pip_install:1                  exit_trap
2017-03-21 17:32:38.201 | +./stack.sh:exit_trap:487                  local r=2
2017-03-21 17:32:38.204 | ++./stack.sh:exit_trap:488                  jobs -p
2017-03-21 17:32:38.207 | +./stack.sh:exit_trap:488                  jobs=
2017-03-21 17:32:38.211 | +./stack.sh:exit_trap:491                  [[ -n '' ]]
2017-03-21 17:32:38.215 | +./stack.sh:exit_trap:497                  kill_spinner
2017-03-21 17:32:38.218 | +./stack.sh:kill_spinner:383               '[' '!' -z '' ']'
2017-03-21 17:32:38.222 | +./stack.sh:exit_trap:499                  [[ 2 -ne 0 ]]
2017-03-21 17:32:38.225 | +./stack.sh:exit_trap:500                  echo 'Error on ...
(more)
edit retag flag offensive close merge delete