Ask Your Question
0

Network related command fail with an SSL Error

asked 2017-03-16 07:37:18 -0500

7r17r1 gravatar image

I'm currently installing openstack following the tutorial for ocata on ubuntu-server. After installing and configuring neutron on the controller and the first compute-node, any command related to the network that I tried failed and returned an SSL Error.

openstack extension list --network, openstack network list and openstack network agent list all return : 'unicode' object has no attribute 'get'

openstack extension list works fine, same for openstack user/service/project list

tried to find a configuration error linked to https or ssl in /etc/neutron and /etc/nova or in the environment variables, nothing.

This is the tail of /var/log/neutron/neutron-server.log

2017-03-08 15:59:40.863 3366 INFO neutron.wsgi [-] 10.0.4.10 - - [08/Mar/2017 15:59:40] "GET / HTTP/1.1" 200 272 0.000515
2017-03-08 15:59:40.875 3366 ERROR oslo_middleware.catch_errors [-] An error occurred during processing the request: GET /v2.0/agents HTTP/1.0
Accept: application/json
Accept-Encoding: gzip, deflate
Connection: keep-alive
Content-Type: text/plain
Host: cloudcontroller:9696
User-Agent: openstacksdk/0.9.13 keystoneauth1/2.18.0 python-requests/2.12.4 CPython/2.7.12
X-Auth-Token: 
2017-03-08 15:59:40.875 3366 ERROR oslo_middleware.catch_errors Traceback (most recent call last):
2017-03-08 15:59:40.875 3366 ERROR oslo_middleware.catch_errors File "/usr/lib/python2.7/dist-packages/oslo_middleware/catch_errors.py", line 41, in __call__
2017-03-08 15:59:40.875 3366 ERROR oslo_middleware.catch_errors response = req.get_response(self.application)
2017-03-08 15:59:40.875 3366 ERROR oslo_middleware.catch_errors File "/usr/lib/python2.7/dist-packages/webob/request.py", line 1299, in send
2017-03-08 15:59:40.875 3366 ERROR oslo_middleware.catch_errors application, catch_exc_info=False)
2017-03-08 15:59:40.875 3366 ERROR oslo_middleware.catch_errors File "/usr/lib/python2.7/dist-packages/webob/request.py", line 1263, in call_application
2017-03-08 15:59:40.875 3366 ERROR oslo_middleware.catch_errors app_iter = application(self.environ, start_response)
2017-03-08 15:59:40.875 3366 ERROR oslo_middleware.catch_errors File "/usr/lib/python2.7/dist-packages/webob/dec.py", line 130, in __call__
2017-03-08 15:59:40.875 3366 ERROR oslo_middleware.catch_errors resp = self.call_func(req, *args, self.kwargs)
2017-03-08 15:59:40.875 3366 ERROR oslo_middleware.catch_errors File "/usr/lib/python2.7/dist-packages/webob/dec.py", line 195, in call_func
2017-03-08 15:59:40.875 3366 ERROR oslo_middleware.catch_errors return self.func(req, *args, *kwargs)
2017-03-08 15:59:40.875 3366 ERROR oslo_middleware.catch_errors File "/usr/lib/python2.7/dist-packages/keystonemiddleware/auth_token/__init__.py", line 332, in __call__
2017-03-08 15:59:40.875 3366 ERROR oslo_middleware.catch_errors response = self.process_request(req)
2017-03-08 15:59:40.875 3366 ERROR oslo_middleware.catch_errors File "/usr/lib/python2.7/dist-packages/keystonemiddleware/auth_token/__init__.py", line 623, in process_request
2017-03-08 15:59:40.875 3366 ERROR oslo_middleware.catch_errors resp = super(AuthProtocol, self).process_request(request)
2017-03-08 15:59:40.875 3366 ERROR oslo_middleware.catch_errors File "/usr/lib/python2.7/dist-packages/keystonemiddleware/auth_token/__init__.py", line 405, in process_request
2017-03-08 15:59:40.875 3366 ERROR oslo_middleware.catch_errors allow_expired=allow_expired)
2017-03-08 15:59:40.875 3366 ERROR oslo_middleware.catch_errors File "/usr ...
(more)
edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2017-07-26 16:55:52 -0500

saif gravatar image

its working for me asw ell

edit flag offensive delete link more
0

answered 2017-03-17 10:33:32 -0500

7r17r1 gravatar image

updated 2017-03-17 10:33:56 -0500

So I managed to resolve this issue by editing neutron.conf and adding :

identity_uri = http://localhost:35357
admin_user = admin
admin_password ADMIN_PASSWORD
admin_tenant_name = admin
auth_type = password

not sure why it needed that though, since neutron is supposed to have admin credential from openstack roles

edit flag offensive delete link more

Comments

under which section you added it . Is it [default]?

hai_senthil gravatar imagehai_senthil ( 2017-07-10 12:11:52 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-03-16 05:31:35 -0500

Seen: 459 times

Last updated: Mar 17 '17