Compute node not showing up in Multi node setup

asked 2017-03-15 09:37:35 -0600

ShubhamMeshram gravatar image

This is the official guide to set up a multi node set up with devstack : the compute node has to be shown in the compute services tab in horizon where the VMs should be launched. Whats the work around for this?

edit retag flag offensive close merge delete


My first suspicion is a problem with the message queue, i.e. the compute host doesn't reach the controller. A popular mistake is incorrect real-time clock setting. Check the Nova compute log on that host (/opt/stack/logs/n-cpu.log by default) for messages regarding controller connection.

Bernd Bausch gravatar imageBernd Bausch ( 2017-03-15 20:11:36 -0600 )edit

1 answer

Sort by ยป oldest newest most voted

answered 2017-03-16 01:03:37 -0600

Vinoth gravatar image

Make sure both the server has same date & time. Fix it manually or use NTP to fix it.

Check nova-compute log, Must be message queue not connected with compute service.

edit flag offensive delete link more


It was the NTP server sync which was missing and one restart fixed the issue. Thank you.

ShubhamMeshram gravatar imageShubhamMeshram ( 2017-03-17 00:04:42 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2017-03-15 09:37:35 -0600

Seen: 453 times

Last updated: Mar 16 '17