Ask Your Question

can't set allocation pools for subnets created from subnet pools

asked 2017-03-09 12:55:33 -0600

xdaxdb gravatar image

I'm trying to configure a Neutron BGP speaker.

Part of the process involves creating a subnet from a subnet pool, from an address scope. This is the exact command from the docs:

$ neutron subnet-create --name provider --subnetpool provider \
  --prefixlen 24 --allocation-pool start=,end= \
  --gateway provider

The problem is that it returns an error about the --allocation-pool option not being available when creating a subnet from a subnet pool.

Bad subnets request: allocation_pools allowed only for specific subnet requests..

I would love to simply leave the option out. However this is an external/physical network, and VRRP is being used on the routers.

The resulting subnet without the --allocation-pool option would assign the .2 address to some virtual entity when both the .1 and .2 address are used by the physical gateways on that external network.

edit retag flag offensive close merge delete


I'm considering just disabling DHCP for the subnet. I don't think the protocol itself is needed but I'm concerned that this will also stop neutron from being aware of IP configuration it needs to function properly.

xdaxdb gravatar imagexdaxdb ( 2017-03-09 14:42:18 -0600 )edit

1 answer

Sort by ยป oldest newest most voted

answered 2017-03-12 09:30:58 -0600

xdaxdb gravatar image

I was able to overcome this by translating the neutron cli command to an openstack cli command, and specifying different combination of options.

openstack subnet create --subnet-pool provider --network provider \
--prefix-length 27 --subnet-range \
--allocation-pool start=,end= \

I think the most important part of the change is including the --subnet-range option which enables the use of the --allocation-pool.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2017-03-09 12:55:33 -0600

Seen: 1,195 times

Last updated: Mar 12 '17